Home        Store        Docs        Blog

Unreliable connection with Fathom X


(Julian) #1

Hi

I am having difficulties with Fathom X: initially when mounted on the ROV, connected via CAT 5 ‘tether’ (for now!) - single pair for Fathom, others unused. Power to on board Fathom X direct from battery (or bench PSU).

Surface Fathom X powered by wall wart (Raspberry Pi so capable of sufficient current).

Ethernet connection seems to come and go.

Remove electronics from ROV, powered ROV Fathom from another high power USB wart (Rasp Pi from yet another). Used new (5 metre) Cat 5 - single pair as before.

Same symptoms - unreliable connection.

When plugged directly connection is solid.

Running out of ideas - any suggestions please!

 

Thanks

Julian

 


(Julian) #2

Further info: looks to me as though at least one of the Fathom-X is not working correctly.

I have taken ROV and Rasp Pi out of the equation, attached Mac book Pro to one end, network switch the other - very intermittent connection - DHCP didn’t work, Ping router failing 99.5% packet loss - very rare success, mostly timeouts.

Julian


(Rusty) #3

Hi Julian,

Sorry you’re having trouble with the Fathom-X. Could be a defective board but we should check a few other things first.

  1. At this point you’re powering both boards from a wall wart, right? Which power input are you using (USB or the black terminal block)? What voltage is the wall wart transformer?

  2. What length of tether do you have connected up? Have you tried a different twisted pair in case that one’s damaged?

Hopefully we can get this figured out quickly - otherwise we’ll send you a replacement.

-Rusty


(Julian) #4

Hi Rusty,

When using the wall warts I measured

4.98V at D1 +, 4.69 at IC1 in and 3.28V at IC1 out

4.94, 4.64 and 3.29.

‘Tether’ is about 20ft of Cat 5 using just one pair (others unconnected).

For the sake of completeness I just repeated the test using the Macbook linked directly to switch - checking the voltages as the ‘ping’ was running, all within a few 0.01V of the above. I also checked the ‘tether’ resistance at < 2 ohm per lead.

Thanks

Julian


(Rusty) #5

Hi Julian,

Okay. This sounds like it should be working well. I think we should get you a replacement board and see if that helps out. Please shoot me an email at rusty@bluerobotics.com and we’ll get that taken care of right away!

-Rusty


(Julian) #6

Hi Rusty

Thank you for your prompt attention in sending out a replacement Fathom-X.

Taken me a while to get around to testing it, as I was tied up with another project. I can now report my findings:

It transpires that one of the original Fathom-X that I had will not work correctly when connected to a Gigabit port (even though it is correctly detected as 100Mbps according to the lights).

I tried with Netgear GS108T, the Fathom-X is correctly identified as 100mbps (according to the indicator lights) - the same story when connected to a Pluscom Gigabit hub. In both cases the link either failed to work at all, or was very error prone (DHCP failed, or DHCP succeeded, then the link would drop).

That one Fathom-X DOS work if connected to a 100Mbps port.

So I now have a working link, whether connected via 100Mbps or 1000Mbps ports - plus one that will only work if connected to 100Mbps.

Thank you

Julian