Fathom x topside box, link no power

Hi, my topside fathom x has the link light but not the power.
Rov wont connect.
Swapped out the fathom x with another but no change.
Also as i remove the unit from the case i pulled the tether connections out, any specific order for those?
Thanks

Hi @mberry -
Please verify you have continuity on the tether pair you are using. It is not necessary to connect the tether wires + to +, - to -, either configuration will work as long as both wires used have the expected (low) resistance.

HI thanks for the reply.

have checked and the connection is solid, the fathom x in the top side box just wasnt powering up, i had a spare and plugged that in and it both power and link lit up but still nothing on the laptop. (done the network setting etc)

its been a few years since its worked…its been a lemon and i never had the patience for it.
Just currently re flashing the raspberry with blueos, see if that changes anything if not ill look at upgrading the raspberry to the new one and get the navigator while im there.

Hi @mberry -
If you’re not able to ping 192.16.2.2, no amount of upgrades will help correct your issue! You should have the link light present on both topside and ROV mounted Fathom-X boards - is this the case? It takes a couple minutes for the Raspberry Pi to start up after connecting the battery and be able to return these pings.
It may be worth trying another USB cable as well?
To confirm, your USB to ethernet network adapter is configured to give you a static IP of 192.168.2.1 with subnet mask of 255.255.255.0 - no other network settings are necessary to configure.
Trying a different tether pair, like the orange/orange white wires could fix the issue as well - this change would be made both in the ROV and the topside FXTI blue box.
Sorry for the frustration!

Hi tony, thanks for the reply once again.
I had link at both fathom x’s, the raspberry pi is dead i believe, hasnt got any lights, ive checked its getting 5v and swapped a few usbs but still not firing up.
had a red light and smelt a bit of smoke being let out so think something has died.
its been sitting for a few years as it didnt work correctly and i didnt have the patience to learn about it, after running a fifish its proved useful for my commercial gig but its a bit light, which has spurred me into getting the blue rov running again, its a bit easier to understand this time around.
(its actually a custom aluminium housed 8 thruster set up)

so ive swapped out the raspberry for another one (have 3 here but unsure if theyre any good)
Ive got a red light, then it flashes 4 long 4 short, no other lights on the rasperberry.
Ive got link and power both ends, just seems the raspberry isnt communicating to the fathom x,i swapped the short ethernet cable out to no effect.
pinging all timed out.
dead raspberry’s??
as you can probably tell im not that tech savy haha
thanks again