Home        Store        Docs        Blog

Fathom-X performance drops


#1

Hi guys,

We have a BlueROV for research purpose. We have installed a multibeam sonar Oculus M750d and a new IMU VectorNav VN100. As discussed here, we met series crosstalk between two twisted pairs. So right now we use two Fathom-X boards and only one twisted pair. However, when we turn on sonar, the IMU received on the laptop drops from the original 200Hz to 160Hz. The bandwidth used by the sonar is 2MB/s, which is much lower than the maximum 10MB/s.

We’d like to keep a higher sonar image rate, meanwhile not to lose any IMU measurement. Do you have any idea or suggestion?

Thanks


(Jacob) #2

@jinkun Without more information about how the system is configured, it is not clear what the problem is. Have you tried a simple bandwidth test with iperf3?


#3

@jwalser I did run the bandwidth test, and it was normal (> 80M/s). The IMU is connected to Raspberry Pi using UART interface, and I create a pty link over TCP. The sonar is connected to another Fathom-X board directly.


(Jacob) #4

Are you reading the IMU with your own program or a 3rd party program? Or one provided by the vendor?


#5

I’m using a ROS package which uses the library provided by the vendor.


(Patrick José Pereira) #6

What is the feedback of rostopic hz /imu_topic when you turn on the sonar ?


#7

The rate dropped from 200Hz to 160Hz with sonar turned on.

I also did a test with network switch and only one Fathom-X board. The IMU rate only dropped by less than 5Hz. But the network switch is too big to fit in the body.


(Jacob) #8

If the link is 80M/s then that is the bandwidth you have, and the Fathom X is working correctly. The other problems you are seeing appear to be with the sensors or sensor drivers. You should contact the manufacturers of those products for more help.