Failing to run auto mission with UGPS2

Hi, we are trying to run auto mission in our new BlueROV2. BlueOS and firmware both latest.

It is connected with waterlinked UGPS2. But when we run auto/position hold mode, the error will pop up: MAV_CMD_DP_SET_MODE command failed

When we turn off GPS and use DVL, auto mode runs normally.

We also have an old BlueROV which uses Pixhawk autopilot (firmware version v3.5.4). That one works well with waterlinked UGPS2.

We thought it might be the firmware version doesn’t work well with UGPS2.

We’ve try changed the setting according to these two posts: https://discuss.bluerobotics.com/t/waterlinked-ugps-for-bluerov-autonomous-navigation/16491/4
https://discuss.bluerobotics.com/t/revert-back-to-ardusub-3-5-4/7527

They both don’t work.

May I know how can we downgrade the firmware or is there any other solution?

1 Like

Hi, can you explain your setup a bit better?

So you have both a UGPS2 and the Waterlinked DVL? How do you “switch” between them?
I suspect the issue is that while using the UGPS2, the ekf is not happy, we need to check why. Can you provide some bin logs?

1 Like

Hi, yes, sure. Which part of set up you would like to know? We have the BlueROV2 which has navigator board.

Yes, we have both UGPS2 and DVL. We disable the DVL extension to turn off the DVL and think that is “switch” between them.

New user cannot upload attachment. May I know your email address or other way that I can provide the log files?

Thank you!

1 Like

To add some extra context here, it’s possible this can work in theory but it’s not something we’ve tried extensively or established as a supported functionality for even the most recent autopilot versions, let alone old ones.

This thread includes some relevant discussion, and this Issue is the latest discussion I’m aware of around fusing those data sources.

The Issue I linked to may cover a potential conflict between the device drivers because of the parameters that they currently set automatically.

I’ve just updated your trust level so you can upload files.

1 Like

Hi Eliot,

Thanks so much for the information! I will look up on them.

Here is the latest binary file that experience the error. Please let me know if you find something about the issue. Thanks!!

log_89_2024-5-24-11-32-46.bin (12.2 MB)

1 Like

A data point that we can provide is, our old ROV which used Pixhawk autopilot can run auto mission with the UGPS2.

1 Like

More information about the error:
There are 8 mode that can choose. The first four modes works well. The same error pops up when we choose any of the last four modes.

image
image

We looked up the MAVLINK command and found some parameter related. I wonder will that helps for solving this problem?

1 Like

Thanks for the extra information :slight_smile:

This log file is very short, but also doesn’t include any position information in the GPS messages or AHRS estimator, which may be the source of your problem.

The failing modes in this case are the position-enabled ones, which only work if the vehicle has a sufficiently stable position estimate. If the position measurements aren’t frequent or consistent enough then the autopilot doesn’t know where it is, so it can’t meaningfully perform position-based actions or missions, and it rightfully refuses to enter a mode that requires such an estimate.

If you check the MAVLink Inspector for the lat/lon fields in the AHRS2, GLOBAL_POSITION_INT, and GPS_RAW_INT messages, that should hopefully provide a sense of what the autopilot is estimating and receiving. I’d also recommend checking the status of the UGPS system and/or the DVL (depending on what you’re trying to use), to see whether at least the sensor thinks it has a valid position lock.

1 Like