Home        Store        Learn        Blog

Excessive Camera Latency / Pixelated Gray Image in QGC

I am having significant latency issues (~2-5 sec) with camera stream on BlueROV2. Not only is the camera feed extremely slow, the few images I do get through are gray and pixelated. The companion software on the Pi has been updated to the latest version. The laptop being used for QGC is running Ubuntu 18.04. Initially, the latest version of QGC was being used (v4.1.1) but I only get a “Waiting for Video” message on the screen. I was finally able to get a video stream by reverting to the last stable release (v.3.5.6) of QGC.

Things I have tried:
In an effort to rule out any hardware issues:

  • Unplugged USB camera from Pi and plugged directly into my laptop. Using gstreamer to view the camera feed, all is working correctly with a clear feed/no latency.
  • Next to rule out tether I connected to the Pi directly from my laptop using Ethernet cable. I get the same results as before in QGC (severe latency). I have also tried gstreamer outside of QGC to view the video stream with the same results.

All gstreamer plugins/libs have been installed and updated to latest versions available for 18.04. I have looked through all the other solved latency issues others have had with no luck. I saw that some have said there are issues on Ubuntu 18.04 on systems with dual graphics cards (mine does) for the newest version of QGC. It seems that may be why I am having issues with no video on the newest version on QGC but not sure if this is the issue I am seeing with latency while using older version of QGC.

I appreciate any suggestions anyone might have or anything I might have missed.

Thanks,
Brandon

We’ve resolved a lot of these issues by experimenting with laptop power sources/settings (plugged in, not plugged in, different power plans). It’s a quick check that might help
Good luck

Thanks Marcus.

I have tried plugged/unplugged with no improvement of camera stream.

I have also tried adjusting my graphics setting from power saver mode (intel integrated graphics only) to performance mode (nvidia graphics card only) with no performance increase in stream.

Hi Brandon,
try this developer version.

Also have a look at this thread: Video freezing and grey frames There you can find a link to the testversion too. This is the only version at this time that runs without any video-issues on my machines. Let us know if it helped.

Cheers
Chris

Hello Brandon,
In my case, the only solution … buy a powerful laptop (Intel I5 + graphic card GTX 1660 Ti) … perfect work now (plugged or unplugged) … no latency, no grey screen, etc …

Thanks for the suggestion. I don’t think power is my issue. I’m using a workstation with i9 and RTX 3000.

Hi Brandon,

:joy::joy: … Sorry :grin::grin: … Maybe this kind of problem can happen if you have a long length of tether coiled on the winch … electromagnetic issue ???
In very low voltage it is quite improbable but it deserves to be tested
You can also try to change the settings of the display size of the PC and also the zoom percentage of the screen …

Hi, can you check the CPU usage in Companion? What Companion version are you on?