Error message: "detected 0 radio channels" . I can not fix this problem when QGControl RADIO calibration

Hi. I need help to fix this problem: “DETECTED 0 RADIO CHANNELS”
I am using CUBE Arduplane, Hereling radio + QGroundControl app.
ALL systems are update. ALL cables are connected and checked.


Does the here link show a connection to the RX? or does the RX show a link to the TX? not used that radio before. If it does show a link between them the next thing to check is if your using inverted sbus or non inverted uart control. Plus other radio like spektrum or PPM might plug in differently to the autopilot.

edit: one other thing make sure your radio is actually outputting signal to the channels. What I mean is once an RX and TX are linked its up to the TX to say how many channels it will send out the sbus and what those channels are.

So I did some looking it seems that is a very nice radio it has DUAL sbus through a single cable that splits out, might double check that the sbus1 is plugged in and not sbus2.

Hi Fred, thanks so much for your support.
I have checked all above twice and the error message appears
I will update Herelink TX/R again tomorrow

Best regards

All system, Herelink TX/receiver, CUBE etc are updated.
All automatic modes, RTL, loiter, and telemetry is working OK
Joystick calibration is OK, but when in QGControl or Mission Planner, channel 3 disappears

Problem is the same here

this is the joystick calibration (ok) before the RADIO calibration in QGC Herelink

Please check parameter RC_PROTOCOLS it MUST BE ENABLE (I selected ALL in the menu)


1 Like