Radio Control on Navigator using SBUS

Hi everyone,
I’m using the Navigator + Raspberry Pi 4 as a flight controller for a UAV. Currently I have the Navigator successfully sending live IMU telemetry back to QGroundControl over Ethernet.
I’m trying to set up Radio Control, and have a FrSky Taranis+ radio controller bound to a FrSky XM+ radio receiver. The XM+ receiver outputs SBUS protocol, and I have it wired to the RC pins at the top of the Navigator board.

The problem I am running into is when I go to the “Radio” tab in QGroundControl, and click “Calibrate” I get the error message “Detected 0 radio channels. To operate PX4, you need at least 5 channels.”

Is there some setting I need to change in Blue OS to allow the RC SBUS protocol to be sent to QGroundControl?

Thanks for any input or ideas!


Running ArduPlane Official firmware (uploaded in Blue OS)
Blue OS Version: tags/1.0.1-0-gbc26236 Build: 4/6/2022, 3:04:28 PM
QGroundControl version v4.2.3

Hi @north,

This isn’t something I’ve worked with directly, but our Navigator technical details do specify SBUS as one of the compatible RC receiver protocols, so I expect it should work. Can you confirm that SBUS is enabled in your ArduPlane parameters?

If that’s already the case then I’ll bring this up internally to see if we can replicate and resolve your issue :slight_smile:

Hi Eliot,

Thanks for your response. Yes I have enabled SBUS in the QGroundControl Parameters tab. I’ve tried setting RC_PROTOCOLS to 8 (SBUS), and 1 (All), then rebooting the vehicle. Neither have enabled the RC Control. I’ve also tried disabling other fail-safes, such as the THR_FAILSAFE and ARMING_CHECK.

This morning I checked the SBUS signal using an oscilloscope, and found a normal looking 3.3V SBUS signal coming from the FrSky XM+ radio receiver into the Navigator 3 pin RC port.

Still getting the same error when I try to calibrate the Radio “Detected 0 radio channels. To operate PX4, you need at least 5 channels.”

Thanks for your continued support with this issue!


Thanks for the extra info - I’ve brought this up internally and will pass on any responses / further suggestions or questions from the team :slight_smile:

I am a little curious about this, because PX4 is independent of ArduPilot firmwares, so maybe there’s a setup issue between your radio+receiver, or in your QGC configuration? QGC’s Radio docs don’t seem to have anything obvious, but I also don’t really know what to look for given my lack of experience with radio control.

Hi @north,

I foudn there’s an issue in the current Linux SBUS implementation. While the proper fix is not merged, you can use this build I just made on top of the latest copter stable release.

Just setting SERIAL1_PROTOCOL to RCIN should be enough.

Edit: Oops, I made a copter build by mistake, I’ll get a plane one up in a few minutes


Hi @williangalvani, I flashed your new arducopter4-2-3-with-sbus firmware to the Navigator, changed the SERIAL1_PROTOCOL to RCIN and my radio communications are now working! YAY, thank you so much for providing a solution!!

Also, ArduCopter is the firmware build I need anyways, I was just trying other builds to troubleshoot.

Thanks again!

1 Like

Hello, I am having the exact same issue above but on Ardurover. Is there a specific build for Ardurover that enables Sbus on the 3 RCIN pins? I have serial1 set to RCIN.

Hi @crypto ,

The latest ArduRover stable should support it fine. Did you give it a try?
If it doesn’t, let me know and I can double check here.

Hello, thanks for your response. I tried to get it working with the Herelink controller. And S bus doesn’t work I plug the S bus connectors into the RCIN port on the navigator. It’s already powered, and I set serial 1 to RCIN.

Sorry about the bad grammar I’m using voice to text at the moment.

Are you using ArduRover? what version?
We had a Quad flying with Herelink for tests, so it should work. Let me know what Ardupilot version you are running and I’ll try to find time to test it again.

1 Like

Ardurover 4.2.3

You used the herelink controller on the navigator RCIN pins? With serial1 set to RCIN? Which port did you plug UART into?


With serial1 set to RCIN


I don’t think we did telemetry at that test. I’ll re-test things and get back to you.

Thank you! I think the Ardurover build may be the issue.

No luck on my end. I tried with a different gcs QGC, and I received a RC parameter missing error.

I checked and the issue is the ArduRover build. The patch is in master but ArduRover hasn’t move on to a 4.3 version for some reason. I’ll get you a build with sbus support early next week.

1 Like

Can you try flashing BETA? that should be 4.3.0-beta8

@williangalvani I’ve tried the latest ArduRover 4.3.0-beta build and SBUS is still not working with the RCin on Navigator, I have switched telemetry to Serial3 and setting Serial1 to RCIN.
Can you point out where the SBUS bug fix is so we can manually compile it in to the rover firmware? Thanks!

Hi @walkwind, welcome to the forum :slight_smile:

I spoke with Willian about this, and he found that the relevant update never actually ended up in the Rover-4.3 branch, so isn’t in any 4.3 releases. It is in the Rover-4.4 branch though, as well as master.