RC Radio connection

Hello, my name is Girish. I am part of a investigation group working on a project to develope aquatic drones. It is my first time working with drones and I was having some trouble with the connection of a RC radio. I am using a DX6e as my transmiter and an AR620 spektrum receiver. The receiver is connected to the navigator through a PPM encoder in the RC pins. After searching on the internet I changed the parameters

  • RC_PROTOCOLS = PPM
  • SERIAL1_PROTOCOL = RCIN
  • RC_OPTIONS = 36
    To calibrate the RC radio and other sensors I have been using mission planner, but even after these changes the program does not detect the radio. Reviewing the Navigator Hardware Setup guide I found that the RC input is configured for SBUS protocol by default and to use UART i would need to take out the jumper and solder it to the UART. Do I need to make this change? Are the parameters that I have used okay, do I need to change any other parameter? I have tried making the connection with a different reciever and transmiter that do support SBUS protocol and it has worked fine on mission planner just by changing the RC_ PROTOCOLS to SBUS, so I am guessing that the problem is the hardware setup or the parameters I have used.

Hi @girish -
The Navigator only supports SBUS, not PPM input. UART is a serial data protocol, not related to PPM. Sorry for the news!

I assume you’re working with a marine surface vessel, as radio waves don’t penetrate water for more than a cm or two?

Yes, water doesn´t penetrate. Thank you for your help.

Following my previous doubt, I have taken into account that the Navigator doesn´t support PPM protocol and have bought a SBUS encoder (JHEMCU SPP-SBUS PPM PWM signal conversion module Interchanger RC remote control receiver). But when I´am trying to calibrate the radio I´am getting an unsual error. The values of my transmitter are changing randomly on its own and I´am worried that this error can occur when I connect it to my boat. I´am getting this error both on mission planner and on QGC. Also I have tried this converter on a Navio controller with the same reciever and transmitter and dont get this error. Thinking maybe it is my Navigator parameters, I have tried using the same configuration mentioned in my previous doubt: RC_PROTOCOLS = SBUS, SERIAL1_PROTOCOL = RCIN and RC_OPTIONS = 36 but with a different converter (Receptor futaba R3008SB T-FHSS) and dont get this error. ¿Is there any additional parameter I should be changing? Any kind of help would be great.