DeepWater Exploration camera on Bluerov

I`m planning to use a DeepWater Exploration HD camera on a newbuild. The whole newbuild is based on blue robotic parts with rasberry P1 and navigator. When connecting the camera exploreHD 3.0 (400m) Underwater ROV/AUV USB General Vision Camera – DeepWater Exploration to the Rasberry the lag is insane! When using the BR usb camera everything works fine. I have tried the DWE HD cam on the topside computer and tested it with a webcam tester and it works fine, but again, via Rasberry its no good at all. For information, there is no tether involved at the time, just bench testing with ethernet cable directly from the rasberry to the topside pc.
Has anyone tried this camera or can come to think of any settings that need to be adjusted in QGC?

Hi @SDI -
The specifications page list the data rate on the camera as 10mbit/s, this is about the same as the Blue Robotics USB Lowlight camera.
Are you running the latest version of BlueOS (1.2 beta 8) ?
Did you configure the stream to use H264, MJPEG, or YUY2?
Are you using Cockpit or QGroundControl?
Keeping the USB Data lines twisted together inside the BlueROV2 main housing can be important to maintain a good USB signal…
It’s possible you may have a damaged unit, but I’m not particularly familiar with the DeepWater hardware. I would recommend reaching out to them for support!

Hi @SDI,

To clarify, by “lag” do you mean latency from reality until the image appears on your screen, or are there stretches of time where no frames are appearing (i.e. like lag spikes in a video game)?

In case it’s relevant, @DeepWaterExploration have previously claimed quite low latency, and others in that thread don’t seem to be refuting that.

If both cameras are plugged in via USB, and using the same encoding type, then I’m not sure what could be causing the additional lag with the DWE camera stream. I would be curious whether Cockpit shows similar lag for the DWE cameras, since it uses a different receiving and decoding pipeline than QGroundControl.

Hello!

You have previously posted on our forums regarding this issue and we are working on a resolution at the moment.

I do think it could be a pipeline issue, as you previously stated that the cameras work fine when directly connected.

Try installing DWE OS with the guide above. If this doesn’t resolve the issue, we can send you a replacement free of charge.

It may also be worth trying viewing the streams on our Discovery software.

Thanks for your patience :slight_smile:

Tony, thank you for your answer. At this time there is no ROV in the picture, just the rasberry Pi, connected directly to the topside PC via ethernet cable, so the usb cables are all inside the jacket , and remember, it works perfect when connected directly to the topside PC usb port and tested.
I will check what version I have on the BlueOS,. I just downloaded it.
I choosed h264 and are using QGC.
If anything I am beginning to think the rasberry Pi might damaged or that QGC has some wrong settings, because the camera works fine on the main computer…

Eliot, the correct term would be latency I guess, as the picture is clear as lon as the camera sits still or there is no movement in front of the camera.

This how it looks like, changes from this

to this, when camera moves or if anything moves in front of the camera.


I did a network test between the topside PC and rasberry

image

Under is the camera view when connected directly to the main computer

We are glad you are not having issues with our camera unit. Please email our support and we would be more than happy to help you resolve your problem with the remainder of your pipeline.

My best guesses in this case would be either:

  1. an encoding/decoding issue
    • often the encoding selected when viewing a directly connected USB camera’s stream is different to one when a stream is being passed on through a network, so it’s possible
      • the camera is struggling with a particular encoding type, or
      • your viewing computer is struggling with receiving/decoding
  2. a power supply issue in the vehicle
    • It may be worth trying to connect the camera through an independently powered USB hub, and/or unplugging any other USB connections
  3. a network bandwidth or reliability issue
    • This seems unlikely, given you’ve measured high upload and download bandwidths and low latency, and are presumably using a wired connection

Eliot
The rasberry is sitting loose on the test bench right now, with the Navigator connected on top.
The camera is the only thing being plugged into the rasberry at the moment.
The power supply is 5V 5A connected to the rasberry via the USB C contact.

After tip from Joseph Ho at the DWE forum i have now flashed the DWE operating system onto the micro SD on the Raspberry, so if I understand this correct, both OS is now on the Raspberry.

My next step now is to try and stream the DWE camera to QGC using DWE OS.

Will it be possible to use both OS at the same time? The DWE for the DWE camera (If it works better) and the BlueOS for the rest?

How do I switch between the two ?

Hi @SDI -
Unfortunately, flashing the DWE OS completely replaced BlueOS on your SD Card! The two OS cannot run on the same Raspberry Pi at the same time - DWE OS seems to be intended for use as a network video recorder, and not vehicle control.
You could install a secondary Raspberry Pi used for this camera, running DWE OS, but this is obviously inefficient!

Can you confirm what model Raspberry Pi you’ve been testing with?

@tony-white
I also thought it sounded strange with two OS on the PI, but the way I read it on DWE page, it is feasable. Or am I reading this the wrong way?

Hi @SDI -
The recommended instructions that involve flashing the SD card with DWE OS will not work in conjunction with BlueOS. They do provide instructions for installing from the terminal - you will need to take the “red-pill” in the BlueOS terminal before running the commands detailed (found by following the link to installation guide in your screenshot.)

However, the screenshot they give seems to be of the default Video Streams page, with their camera active - perhaps it will show up at the port they reference when installed?
image

This seems to completely ignore the intended BlueOS extension infrastructure, so let us know if this approach is succesfull!

I have Four Heavy’s installed with a 100m 4pair tether. I use blue OS was on 1.1 beta when I got them and I am now on 1.2.2. I have no issues I don’t run their software, however I couldn’t get them to work at all at first. What is not told depending on the type of cable you have is you MUST !!! twist by hand the data wires ALL the way from the wetlink to the hub. Doing this I am able to view all four camera’s by just switching ports. No lag looks great and feel like its better in the new blueOS.

1 Like

The setup is not yet even inside the ROV. it is sitting on the testbench still. below is a picture of the set-up. The left USB is used for the DWE for testing, the right usb i s for the bluerov cam.
Bottom picture is showing the pixilisation problem

image

Not that this is any help, but I have noticed that while I a CAN use the cameras in qGC and in Cockpit, the feed is more responsive and less subject to occasional freezing when using discovery. So maybe try downloading their free lite version of discovery and see if that helps.

Now I personally as a hobby user don’t think I’ll pay subscription to use a video player.

DWE guys come on your cameras are 400.00 starting point up to thousands why nickle and dime your paying customers. As users having spend neraly 4k on your cameras feels like this should be tucked in free so that post like the OP’s don’t show up.

Hi @SDI !
Some old hints that might help.
Must be encoding or decoding of H264 stream that hick up, probably from some processing hitting 100% load.

Using same resolution on screen as camera?
If so no remapping has to be done.
Also check load on processor and graphics card in computer:

Do a check that QGC uses hardware acceleration:

Hi. The issue was the factory set bitrate on the DWE camera. The bitrate was set to 10Mb. After sucsessfully installing the DWE OS I was able to change the bitrate. I tried the max fixed bitrate of 15mb, but that was not sufficient. I then tried variable Bit Rate, VBR, and everything was fine. I do not know however how many bitrate it takes when set in VBR mode.

1 Like