Home        Store        Learn        Blog

Connection Timed out

Hi I reconnected up our ROV to test in the lab and when connected to QGC I got video feed but it showed the ROV as disconnected. on 192.168.2.2:2770/System it showed no version of Ardusub as shown in this post: Ardusub Version: Not found however after clicking the reset to defaults on MAVproxy i can no longer get onto 192.168.2.2/2770 and I get a timed out issue when trying to connect or ping the IP I get a network timed out error I’ve tried connecting on two different computers

any suggestions on how to fix this?

Hi @TANC, welcome to the forum :slight_smile:

These aren’t related, so there’s likely some other issue going on. I sometimes need to restart the ROV and re plug in the USB cable from the fathom-X to my computer, but you mentioned you’ve already tried with multiple computers, so I’m assuming you’ve tried that.

The other things I’d jump to next are

  • checking your power supply
  • making sure your topside computer IP is still on the 192.168.2.x subnet
  • seeing if the red power LED on the Raspberry Pi (near the camera) is lit up, and the green ‘SD card activity’ LED next to flashes a bit on startup to show that it’s doing something (if not you may have a corrupted SD card - you can try re-flashing it, but may need to replace it)
  • seeing if the main (big) Pixhawk LED is orange (underpowered) or flashing blue (ready, no GPS)

For your original issue of ardusub version not found, we’d normally recommend going through our set of troubleshooting steps :slight_smile:

Thanks, re-flashing the SD card solved the problem

1 Like