Connecting Ping 360 to Ping Viewer

@gcelec You are going to need to use the Test Release t2.0.2 with Ping360: Release Test Release (t2.0.2) · bluerobotics/ping-viewer · GitHub

I think it’s the wrong link on the Ping 360 Page that takes you here
https://docs.bluerobotics.com/ping-viewer/#installing-and-running-the-application

The download links on the Ping360 product page should all point to t2.0.2, let us know if you find one that isn’t.

Ping Viewer links to the old version

ping-viewer v1.1.1 is stable and supports only the Ping Echosounder. The Ping Echosounder product page and other site-wide ping-viewer documentation points to this version.

ping-viewer t2.0.2 is not stable and should only be used by Ping360 users at the moment. The Ping360 product page links to this version.

We expect a new stable release with support for the Ping Echosounder and Ping360 at the end of the month, at which point all of the links will point to ‘stable’.

1 Like

Hi @gcelec,

Thanks for pointing this out. We fixed the download button on the Ping360 page so it points straight to the right version.

-Rusty

1 Like

2 posts were split to a new topic: Set static IP for Ping 360

I am having issues connecting the Ping 360 to Ping Viewer. I am trying to run it over ethernet using the Blue Robotics ethernet switch since I have a DVL connected as well. When having ROV connected to topside interface, the Ping 360 will not appear on Ping Viewer. I am using version 2.3.4

We ran many tests to see if it is a hardware issue. The Ping 360 connected with a direct connection from sonar to computer. From there we did direct connection tests through the ethernet switch as well as through the fathom-x. But it did not connect through the ethernet switch or through the fathom-x either. It should be noted that the vehicle does get telemetry and the DVL does connect so that means the ethernet switch and fathom-x are working properly. So I am trying to understand why the Ping 360 does not work through the switch or fathom-x.

A few times when trying to connect over different ports on the ethernet switch, the 360 would appear on Ping Viewer, but when trying to run it, it would be a blank sonar that wouldn’t run. I don’t know what that means and was curious about that as well.

Hi @Jnyberg,

Has your Ping360 been configured for ethernet communication? They ship configured for USB, and the cable needs to be changed to a different port internally if you want to use ethernet instead.

If it has already been configured for ethernet, what did you mean by “a direct connection from sonar to computer”? Was that before it was re-configured?

If you do a “manual connection”, it will display the selected device type’s default interface while it attempts to connect to it. Sometimes manual connections will be remembered by Ping Viewer even if it wasn’t able to successfully connect to a device, in which case it might appear in the normal connection slot even without a device being there.

Alternatively you may have seen a device that was detected by Ping Viewer, but not reachable for general communication, in which case it may just not be receiving any data.

Yes we made sure to check that first as a sanity check and have it on ethernet.

What I meant by that is we opened the Ping 360 and connected it directly to our computer from there using a RJ45 to JST-GH adapter board and an ethernet cable. With that it did connect.

Would that mean there is an issue where we are losing communications through either the ethernet switch or fathom-x? Because it does work like mentioned above.

Good to know :slight_smile:

Ahh ok, that makes sense, and good to confirm that your sensor does definitely work in its current configuration.

An “unreachable” device would be more likely due to being on a different subnet or similar. That said, it does seem like the issue here is either the Ethernet Switch or Fathom-X, because you’ve confirmed that the Ping360 works when not going through them, and all they should be doing is passing on the signal.

Are the normal ROV connections (telemetry + video) working through the Ethernet Switch and Fathom-X? If so, could you try connecting the Ping360 to the port that’s currently being used by the ROV, since that’s at least confirmed working?

Yes they are we recieve telemetry and video. The rasp pi is connected through port 1 (through ethernet port) on ethernet switch with fathom-x connected to port 5 (through ethernet port).

When I connect the ping 360 to port 1 on ethernet switch (making sure to unplug rasp pi that is connected via ethernet port) it does connect on Ping viewer, but the rate is very poor, nor smooth. I would say it takes over a minute to do a full rotation on the sonar scan.

For the heck of it I tried connecting it to port 5 as well, moving the ethernet port connection of fathom-x from 5 to 1. But that resulted in it appearing on ping viewer, but not running at all.
And just to confirm, ping 360 hooked up on other ports resulted it no connection appearing on ping viewer at all

Could you explain how I could check for this? Like do you mean subnet on sonar or on my computer? Because I have the subnet on computer set as 255.255.255.0 as it should be I believe.
image

And I can’t find a spot to change it for ping viewer. All I see is this:


image
It does warn to configure subnet if necessary but I don’t know where.

To note I also tried different IP addresses like 192.168.2.84 and 192.168.2.14 just to see if maybe 192.168.2.4 has conflict with another thing but that did not seem to have any affect

Hello,
I face the same problem the IP did not appear in the Ping viewer but when I change the communication through USB the Ping 360 worked. I think there is a problem with the ethernet switch.

Also, I switched the port from USB to Ethernet the Ping Viewer did not recognize the Ping 360

@Ibrahim I believe you are on to something. I tested again using a different ethernet switch from BotBlox (SwitchBlox - Small Ethernet Switch 5 Port Network Switch) with just external wiring and got it to work via ethernet.



So @EliotBR for whatever reason, the problem does seem to be coming from the Blue Robotics ethernet switch (https://bluerobotics.com/store/comm-control-power/tether-interface/ethswitch/)

For now we have the BotBlox switch mounted, but are wondering why the Blue Robotics switch doesn’t work. We would still like to use the Blue Robotics and hoping to resolve this issue

Update: Have the BotBlox ethernet switch fully mounted and wired up. Tested now and have connection to Ping 360. Here is how it looks:



For reference, we have rasp pi connected via port 1, fathom-x connected via port 5, Ping 360 connected via port 2, and DVL connected via port 4.

An extra thing to note is that for sanity check, we tried to test sonar back through just fathom-x, but could not get connection. So that is still disconcerting.

The subnet of the sonar’s IP should be the same for the computer’s IP - e.g. if the sonar is on 192.168.2.4, the computer should also be set to a 192.168.2.x IP address. I don’t expect that’s an issue here.

I don’t expect there’s a problem with the ethernet switches in general (several of us in BR use our Ping360s through our ethernet switches), but it’s possible there’s an issue with your particular ethernet switch, in which case I would recommend both of you contact support@bluerobotics.com to sort out a replacement (or refund) as relevant.

That’s definitely odd (it works fine for me), and makes me curious whether it could be the issue instead of the ethernet switch. Does it work to do Ping360 → eth switch → topside computer, bypassing the Fathom-Xs and tether?

It’s possible you could be running into bandwidth saturation problems through your tether, so maybe run a network test to see what the BlueOS download speed is from your vehicle?

A good idea to test for that. Here are the results I got

Next I ran through BlueRobotics switch with topside computer connected to ethernet port 5. This was tested with multiple ethernet switch boards we have that Blue Robotics supplies.

  • Through Blue Robotics ethernet switch (Ethernet port 1):

    • It connected and ran smoothly with minor lag
  • Through Blue Robotics ethernet switch (Port 1):

    • It connected and ran but with significant lag
  • Through Blue Robotics ethernet switch (Port 2):

    • Appears in Ping Viewer but can’t connect
  • Through Blue Robotics ethernet switch (Port 3):

    • Not appearing in Ping Viewer
  • Through Blue Robotics ethernet switch (Port 4):

    • Not appearing in Ping Viewer

Putting topside computer connection to ethernet port 1,

Do you know what it means when the Ping 360 is able to connect through the ethernet port 1 but struggles in same port 1 on the ethernet switch?

I ran some network tests with different scenarios like ROV through BotBlox ethernet switch (with or without the other cevices running), ROV through Blue Robotics ethernet switch (with or without the other cevices running), and ROV directly to fathom-x. With each of these I did 3 tests and got same consistent results of download speed of 72.73 Mbps and upload speed of 80 Mbps

hello,

Do you find the solution for ping 360 by the ethernet switch from blue robotics?