Trouble Installing New Ping360

Thanks, in advance

I have an older BlueRov R1 (Oct 2017) that I have just been updating the main components (updated Pi and Navigator and added an Ethernet switch) which so far has been going OK (I may still have an issue on the older power sense module but that would be a separate post)

The unit was tested and was communicating via as normal in both QGroundControl and Cockpit (Video lights and motors all working as expected)
QGroundControl 4.2.8
Ardupilot 4.1.1
BlueOS 1.2.0-beta.4
Pingviewer 2.4.2
I have now added a Ping 360 connected to the new ethernet switch which does not come up on the Pingviewer devise manager nor the BlueOS ping sonar devises.

I suspect that the Ethernet switch is working due to being able to send and receive data down the tether (approx. 30Mbps each way – 200m slim) and the video feed and commands to the motors, additionally the LED’s (1,4 &5) on Ethernet switch are flashing green (Ping 360 connected to port 4)

Upon opening the Ping 360 there is a continuous Amber LED (under the board) which is lit
On power up of the Ping 360 there is a Red LED (under the board) which strobes (I think 3 times) prior to the Amber light coming on. I have also seen this strobe continuously red without the amber light coming on

I have had a look through the installation guide but cannot see anything. I have looked at the firewall settings but pingviewer.exe is not displayed.

Any assistance would be appreciated.


Hi @Scott_W
Just to verify, when you opened the Ping360, the data wires were plugged into the JST-GH connector marked for Ethernet? By default they are plugged into USB… An easy change to make!

Hi Tony

Yes I should have clarified that I did change over the defult set up of the Ping 360 from USB to Ethernet and that all of the above was done after that change


Hi @Scott_W -
I would recommend connecting the Ping360 directly to your computer and verifying it is set to use the correct IP address. I’ve found that Cerulean’s SonarView works well to discover the device and change its IP address as well (also available as BlueOS extension), you could try seeing if it detects the device before making a direct connection?

Hi @tony-white

Thanks, it looks like we are getting somewhere

I connected the Ping360 (direct at the board) with a JST-GH connector to a ethernet plug adapter then the classic ethernet cable and then USB adapter direct to the Windows PC and fired up the system

I then started Ping Viewer (it was already installed on the PC) and it saw the IP address straight away. Now I can see 360 in Ping Viewer

I will start swapping out cables from the Ping 360 back to the Ethernet Switch and see how that goes


I have noticed that when I click on info it does not seem to see the devise “fully”

Hi @Scott_W -
The problem is evident in your screenshot! The IP address is not properly configured. Click the settings gear next to it, and change to or similar. After updating the firmware the IP address will reset to the value you saw of
Once configured correctly, it will be at that static IP on the same subnet as the vehicle, and BlueOS should recognize it without issue.

You can of course use Cockpit or QGroundControl alongside PingViewer, but I like installing the SonarView extension and embedding an iframe widget on a cockpit screen, to then get ping360 data in the same window as your video!

Hi @tony-white

Complete power down (laptop and ROV) reboot (Virus potections [AVG] and VPN [Nord] both turned off)

The Pingviewer found the Ping360 on attempted to change it to a static they system looked for a device and discoved the Ping360 on the same IP address as previous

Checked what “seemed” to be available ( and still showed No Ping device/model/Firmware/ID

Checked vehicle (although the Ping is bypassing the ROV Pi - it is still a direct ethernet connection to the laptop) connected (via cockpit) at and confired data being transfered

Attempted a manual connection to the IP address shown in the device manager ( and still no connection (showed No Ping device/model/Firmware/ID)


Hi @Scott_W -
Now that you’ve configured the IP to be at, you should be able to connect it to the ethernet switch. BlueOS will then detect it on boot, and you’ll see an option in PingViewer to view the data when connected to the ROV.
You shouldn’t need to do a manual connection - the device should be recognized automatically, as your screenshots seem to indicate is happening?

Hi @tony-white

First off thanks for your patience

Complete shutdown (ROV and laptop) reconnect the Ping360 via its cable to the Ethernet Switch.

Restart as before (Virus protection etc off) after the “normal” boot time of the ROV either Cockpit or QGroundControl will both connect to the ROV

After approx. ?3min? (didn’t time it) Pingviewer saw the Ping 360 at and I clicked on the IP address to connect it in Pingviewer (Note neither the BlueOS Ping tab nor the Cerulean’s SonarView (Extension in BlueOS) found the Ping 360 at (in the SonarView I tried the default search and a device discovery search)

This still did not “see” the Ping360 fully see attached image

Also this caused (both) Cockpit or QGroundControl (running only 1 at one time) to have near continuous loss of connection to the ROV and then reconnection, although the video stream during these disconnections was maintained and active (no loss of movment in the video but loss of control motors, lights)

During this near continuous loss of connection/reconnection to the ROV I did run a speed test (sorry no screen capture) but it was about 30 odd Mbps both up and down with latency hanging around to the 30ms

Jiggled all data connections (fxti, tether, ethernet switch connections etc) no change

Thanks in advance

Hi @Scott_W -
This is mysterious! To rule out a problem with the hardware, can you try connecting over usb? It seems like an IP configuration miss-match either on the sonar or computer side. Be wary of the red and green dots, they are not usually correct especially when using manual connection. Also, gui logs might help us debug your issue if it continues. After verifying the sonar connects and scans when used via USB directly with your computer, please change back to ethernet and try:

  1. Set computer IP address to auto
  2. Plug ping360 directly into computer
  3. Open ping viewer and wait for a few minutes.
  4. If it shows up with a link-local address, change the sonar to desired static IP address.
  5. Close ping viewer and change the computer IP address to match the sub net ( or similar). Open ping viewer again and wait for it to show up.
  6. If it doesn’t show up change computer to and wait a few minutes and it should show.

You can find the GUI logs under PingViewer folder in your Documents folder.

Hi @tony-white

I think we are starting to get somewhere

Connected the ST-GH connector of the USB plug direct to the Ping360 board and the then to the computer and had successful communications and data transfer (see image)

I also then connected the ST-GH connector of the USB plug to the Ethernet switch side of the ST-GH connector/ ST-GH connector (to check the Ping360 cable) and this also successfully connected to the Ping360

I then connected the ST-GH connector of the Ping360 board to the RJ45 adapter and then to a “standard” blue ethernet cable to the Gigabit Ethernet Adapter to USB to my laptop.

This saw the ping come up at the IP address I then changed the computer IP address to (Ethernet 4) and reopened Pingviewer, this then again “saw” the Ping360 at but when clicking on the Ping360 again it was not fully connected

Uploaded GUI and Sensor Logs from today (69.7 KB) (1.6 MB)


Hi @Scott_W -
Are you saying here that you were able to communicate with the device over ethernet when connected with a short cable? Or you were only able to get data on the display when connected via USB? Please verify that you have set the subnet mask properly when configuring your static IP address (

If the unit is working when directly connected via ethernet, but not when in the ROV, I would investigate what ports you’re plugging into on the ethernet switch. If it’s not working at all when connected via ethernet, only responding to pings and showing up in PingViewer but no data, it may be worth a call with our support team to troubleshoot. Please reach out to arrange with our team next week.

Hi @tony-white

A Clarification when I “checked” and connected this was via the USB on the “downstream” side of the Ping360 integral cable so commnication (at that time was via USB)

I set the subnet to (IPv4 mask as per the screenshot)

The unit is not working via the Ethernet (and has not been seen to work at any time it can be “seen” but not getting data as seen by version number of the Ping360)

Happy to reach out to the team


One thing that may explain your problem - if 5V USB is connected when the Ping360 interface is internally connected to ethernet, this will damage the ethernet interface - but the unit will function normally via USB. Hopefully this hasn’t happened - we’ll discuss next week. Thanks!