Ping360 not working through Ethernet and Low Bandwidth on brand new build

I have just bought and assembled a brand new BR2 rev4 by following the great online guides, alas the Ping360 does not work through the Ethernet Switch, it works fine through the RPi USB, but wont show on Ethernet.
I have followed the tutorial, also followed all troubleshooting I can see on the forums. Ping viewer is added to the firewall allowed list too. The Ping360 just wont show up in BlueOS or in Ping Viewer when attached to the Ethernet Switch.

I am also experiencing low bandwidth <20Mbs and the camera is lagging (thanks for adding the spare camera btw as the one installed didn’t work). I have 200m 4 UTP tether (although all coiled in the reel so could this be causing residence?) I notice that different browsers offer different readings with Edge being the worst, then Firefox and Chrome the best on Windows, Safari on MacOS beats all of them though - however every tests ends in an error.

Hi Marcus,
Assuming that you have done the internal swap over to ethernet interface inside the Ping360 - as per here:

Noting precaution of “If the Ping360 is changed over to Ethernet communications, DO NOT plug it into a computer via the USB connection, it will damage the transformer on the Ethernet configuration.”

My first port of call would be to connect the ping360 directly to an ethernet router to which the topside computer is connected. By default the ping360 is in dhcp client mode, so will grab an IP address from the router and you can then at least confirm the function of the ping360. If you can then establish a connection, best to chang ping360 to the default choice of “192.168.2.4”.

In regards to bandwidth, can you confirm bandwidth without the ethernet switch in the loop i.e. raspberry pi connected by ethernet directly to ROV Fathom-x board. This will confirm if the switch is causing any issues.
You can also try a different pair in the tether to rule out an issue with that particular pair of connectors in the tether - need to swap both ends

1 Like

Hi @3dMB -
Did you switch the internal interface of the Ping360 to ethernet? Luckily, plugging USB into ethernet won’t damage it, but the reverse, ethernet into USB connection, is not good!

What version of BlueOS are you using? The tether being coiled is actually better for bandwidth then completely uncoiled, in my experience…
I would recommend you verify the tether leads are not reversed - the system can still work but at lower bandwidth if this has occured. To check:

  1. Open ROV enclosure, and rotate so the Fathom-X is bisible.
  2. Open the FXTI enclosure so the Fathom-X is visible
  3. With a multimeter set to continuity test (audible beep when leads touched together) verify the large green screw terminal + wire in the ROV FathomX is connected to the corresponding location on the FXTI Fathom X.
    I hope that helps!

Thanks Matt,

I had actually missed the changing interface link when going through the Ping360 installation guide.
I did change it over and it did show in Pingviewer, however the hardware didn’t start up scanning - maybe something to look more into another day.

Since booting back up, some tests will run at upto 60Mbs, however some still remain sub-20Mbs - these are tests that are run back to back.
I have isolated the Ethernet Switch so the RPi is direct into the FXTI, I have switched UTP on both ends to see if a tether core issue, I have tried 2 laptops, and there seems to be no rhyme nor reason to what is going on. With the Ping360 plugged into RPi USB it absolutely kills the bandwidth and seems ot take the CPU load up - but bandwidth does also go when the P360 isnt plugged in - Confused.com

A couple of screen recordings:




Hi @3dMB,
Can I ask which version of BlueOS you are running? I would certainly recommend uodating to latest beta 1.2.0-beta 8.
From my experience the network speed test in the older BlueOS releases used to act a bit strange when you had both a wifi connection from the ROV to router and the tether connection. Later versions of BlueOS allow for separation of these in the test tool. This might allow us to look into it in more detail.

In regards to the ping360 not starting scanning even when connected, I’ve not come across this before @tony-white, is this behaviour you have seen before?

I’ve just noticed that in your video, both the ping1D and ping360 are both reporting as being on IP address 192.168.2.2 which is the IP address of the ROV, I assume that was when it was connected by USB? Did you set the static IP address for the Ping360 to 192.168.2.4 as recommended?

Kind regards

Matt

Hi Matt,
I was on 1.2.0-beta 1, however have just updated to beta8.

Today I sent it for a swim, I started with a 8th gen-i7 Dell 5424 as topside machine and the bandwidth was truly awful with huge camera lag. I then changed to my M1Max MBP and it was faultless. I have seen many using the Dell 5424 as topside for these hence why I bought it. The task manager didn’t show the Dell to be anywhere near capacity when running so a little confused on that.

On the video, both pings were over USB.

Now I am home I am trying to sort the Ping360 over the Ethernet switch but still no no avail. I have changed the plug inside the unit to ethernet. I have the latest version of ping viewer. I have on occasions had the Ping360 visible - normally with a red blob, not blue. I have had it green twice with IP 169.254.146.11:12345 which does not fire up the unit if I select it. Selecting static IP and inputting 192.168.2.4 removes it from the list and I am left with only the Ping1.

I have successfully plugged my DSLR in to the ethernet switch and seen that on EOS remote on my laptop so the switch seems to be fine - just a fight between the switch and the P360.

The following screenshots are all from today with the P360 plugged into the switch.
o



Hi @3dMB
After setting the ping360 to 192.168.2.4, have you tried to connect to it via a manual connection in ping viewer as per button 5 in image below:

You should connect to 192.168.2.4 and port 9092 but also try 9090.

absolutely - but I am faced with a blank 360degree sonar screen and the P360 doesn’t fire up

@tony-white do you have any insights here? Definitely not something we have experienced before.

Hi @3dMB,

When the Ping360 is in ethernet mode it typically uses port 12345, so that’s worth a try as well (although I would expect it to be showing up automatically in Ping Viewer, assuming the static IP configuration was successful).

Port 9090 and the surrounding ones are used by the BlueOS ping service when bridging a USB-connected ping device to a UDP connection for Ping Viewer to connect to.

This is the case for any manual connection when there’s no device on the other end (Ping Viewer is just waiting for it to respond) - if you connect to a random port (e.g. 192.168.2.4:1000) then it will do the same thing.

Right chaps, here we go: https://youtu.be/Bq5BkJLQTe0?si=RbQT8PXBjiDRJFx6

Hi @3dMB -
It looks like everything is working ok until you go to change the IP address.
You may want to try using SonarView - in some circumstances I found that it finds and changes the IP more reliably, but a big update for PingViewer is almost ready!

any thoughts on this @EliotBR?

Thanks Tony, any idea on timeline of the update, please?

Hi @3dMB - I hope soon, but I would not rely on it correcting the problem necessarily… Have you tried changing the IP via SonarView in the meantime?

working away so no joy yet - also the MacOS version download isn’t currently working

Hi @3dMB -
I should have been clear, use the SonarView BlueOS extension, from the extension store, not the standalone application.

ok, will look into it once home - thanks

You may also be able to get the mac version of SonarView working by following these instructions to open…

Alas it does not show in SonarView either when P360 is on Ethernet - USB only