Compinon computer address is different

I want to build my own vehicle. I am the beginner. We bought bluerobotics rov2. Now we want to build our own vehicle for that i started with pixhawk and raspberry pi.I connect the raspberry pi cam to raspberry pi and pixhawk is powerd on using telemetric port2 and raspberry pi. I flashed ardusub rasbian to pi and ardusub to pixhawk. QGC is used but the vechicle video is not coming and it is not connected then i ping the compinion computer i.e pi from putty then the address of that is not How to change the compionion computer address. I am attaching the picks of connection, putty ,QGC and ipconfig.
Thank you.

I spoke with @williangalvani about this and he said

In addition,

  1. have you set up your network settings and allowed QGC through your firewall, like in our software setup guide?
  2. does the companion web interface work?

Thank you Eliot for quick response.

Yes, I have setup the network settings and allowed QGC. Companion web interface is working but QGC was not connected. I am attaching the picks also. Please find them.

Given you’re able to access the web interface at, and it’s also listed as one of the options in your hostname -I call, the IP address isn’t the problem.

In this photo your Detected Devices doesn’t show a detected Pixhawk, so it looks like it’s not connecting correctly. It’s possible you haven’t connected it correctly, haven’t powered it correctly, or don’t have the correct firmware running on it.

Looking again at your setup photo, it doesn’t look like you’re powering the Pixhawk. It also looks like any power that it does happen to be getting will be via a pin from the Raspberry Pi, which isn’t recommended. Normally we power both the Pixhawk and the RPi via a 5V6A BEC connected to the main battery power. Our Hardware Connection Diagram is a bit confusing because it shows two BECs, but only one should be required (the idea is they’re both powered by it - I’m looking into making that diagram a bit clearer soon).

That connection diagram also shows our normal method of connecting to the Pixhawk, via a USB to microUSB cable from the RPi. I haven’t tried connecting to the Pixhawk’s telemetry port from the RPi GPIO pins, so I’m not sure if your wiring there is correct - a USB connection would definitely be easier to help ensure that connection is correct.

When your Pixhawk is correctly powered up and connected the main light should be blue and flashing on and off.

oh,I want to say I also meet the preoblem .I couldn’t connect to the web. Then I entered the terminal through the raspberry pie connection screen and keyboard. I found that the default IP of raspberry pie was changed to When I change the computer IP to the IP of the same network segment, I can directly access the web interface. The raspberry pie firmware is 0.0.18


As above, the is a link-local address, and doesn’t meant that the companion computer isn’t also accessible via the normal address.

This is always required. Have you tried setting your computer’s IP to, as is expected from the network setup? (and more generally, have you gone through our software setup guide? :slight_smile: )