Camera failed, or Pixhawk?

Recently, our BlueRov 2 stopped sending video over to QGroundControl. BlueRov 2 has responses to all other control signals like moving, lights up/down, gains, etc. The gesture is measured correctly in QGC. Camera gimbal is working (up, down, reset) via gamepad control. The only thing missing here is the video.
Running on Companion 0.0.31 and
On the system page, under detected devices:
Vido Devices: None!
Audio Devices: None!
Serial Devices: Pixhawk1
I connected the raspberry pi 3 to a monitor, it says:

    Detecting Ping Devices:
    Checking if usb-ArduPilot_Pixhawak1_3fxxxxx is a ping device...
    Opening /dev/serial /by-id/usb-ArduPilot_Pixhawak1_3fxxxxx  at 115200 bps
    An exception has occurred: Failed to open the given serial port: (32, 'Broken pipe')
    Unable to identify device at ArduPilot_Pixhawak1_3fxxxxx 
    No screen session found.
    No screen session found.
    No size specified (using byte-data access)
    No size specified (using byte-data access)
    Navigator not detected.
    No navigator board detected

The camera itself should be working as I’d tested on some windows machine, where it could be used as a video camera.

So, here I’m thinking its the Pixhawk problem. But it has responses when gamepad is connected. Any suggestions? Thank you.

By the way, it is a pixhawk 4 used in BlueRov 2, right? Where I can get a replacement for it? I’m in Australia. Thanks again.

This is a camera / Raspberry issue.
The pixhawk is only doing telemetrics, such as thrusters, sensordata, lights etc.
The Raspberry pi is distributing the video.

When video device is not present it’s most likely something wrong one of the following:
The camera itself, the wiring (usb to camera) or the powersupply for the Raspberry.

As you have mentioned, you have succesfully tested the camera directly to a usb on a computer.
So you can look away from issues with the camera and propably the wiring.

Next step is to check the powersupply for the Raspberry. If you have other components connected to the usb’s on the Raspberry that drag the voltage down on Raspberry, the first thing you lose is contact with the camera. Unplug other usb-connections, reboot and see If there are any videodevices appearing.

I have seen some cases with the Ping altimeter where the powerconsumption is causing the camera to mailfunction.

Hopefully this will lead you in the right direction.

Espen Johannesen

1 Like

Hi Espen,

Thanks for the help. Actually I’ve tried replacing the raspberry pi 3 with another one. It showed exactly the same problem. Raspberry Pi has only the camera and Pixhawk on its USB ports.

On the other hand, you did provide a good point: the power supply. If by any chance the power supply to Raspberry pi is not sufficient, it may cause strange problem. I’ll have a look at it later.


1 Like

Hi @Ran,

@Espen has covered the main troubleshooting steps here :slight_smile:

On the powering front, I would note that we generally recommend a 5V6A BEC that directly powers both the Raspberry Pi and the Pixhawk (some further notes here). Many other regulators have a lower current capacity, and it can also be problematic to power the Pixhawk only via the Raspberry Pi USB port because it can end up drawing too much current and under-powering the RPi.

The error messages in your post aren’t particularly insightful in this case - Companion tries to configure any connected USB device as a Ping device in order to detect valid ones (hence the “unable to identify” portion), and Navigator is a different type of autopilot board that we check for.

Nope, Pixhawk 1, which is unfortunately no longer manufactured.

Hopefully you’re not in need of a new one, but if yours ends up being defective or something then you can contact to sort out a replacement.

Pixhawk 4 can also work, although the setup isn’t quite as simple. We’re also finalising testing of our own autopilot board, which should hopefully be releasing reasonably soon.

Final Update:

I believe now the fault was with the camera. I noticed that when the camera was inserted with other computers, there were random intermittent broken images. Sometimes the camera could not be recognised by some desktops. After examining the camera circuit board and wires, I found there was some problem with the wire welding points. I re-worked these wires and then BlueRov had the video back.

As a result, I ordered a new camear from BlueRobotics and it is now in working order.

1 Like