Home        Store        Learn        Blog

Unable to get companion software to detect pixhawk or camera

Hi,

After taking over the bluerov2 from another guy (was working, but had a leak; leak fixed), the video was not working and all the firmware was out of date.

I have downloaded the latest QGroundControl (won’t auto connected to the bluerov); so I updated the Companion software from 0.16 to 0.22 - no difference; pixhawk appears as a device, but the camera doesn’t.

So I tried update pixhawk from 3.5.3, but unable to do so via the companion web interface; so I attempted to do so by direct connection; still unable to; I replace the pixhawk with a spare one updated with version 4.0.1. The pixhawk and the camera both cannot be detected;

The I replace the Raspberry Pi with a spare one updated to 0.22. Still pixhawk and camera cannot be detected. Not sure how to proceed … suggestions?

Just to note that the pixhawk version is 4.0.2 (latest stable - not 4.0.1 - my bad)

To confirm the USB cable from the Pi to the pixhawk is ok, I’ve executed the command at the terminal:
ls /dev/tty*
“if pixhawk usb connection is detected you will see /dev/ttyACM0”
I confirm that I can see “/dev/ttyACM0”

Well, it wasn’t ttyACM0 … it was ttyAMA0 - see attached picture.

Also, I’ve changed the 5V 6A power supply to the Raspberry PI and pixhawk, but it doesn’t seem to make any changes.

HI,

Have you checked that the PI is a 3B and not a 3B+?

We have found the 3B+ is not compatible.

Kind regards

Deep Supplies

Thanks - I checked - it’s a 3B.

However, I think I found the problem. I decided to break the problem of the pixhawk and the camera not talking with the PI by just connecting the pixhawk. that finally worked. the pixhawk will talk to the PI on it’s own, so I replaced the camera. and now both work. I think the camera has shorted out drawing too much current so that the PI cannot talk to the pixhawk.

1 Like