Unable to connect Blue ROV2 to QGC

I cannot see Pixhawk autopilot under the serial devices list. How to resolve this problem? I think this is the reason why I cannot connect the Blue ROV2 to QGC. I have another Blue ROV2 and that is working perfectly fine.

Hi @Surya, welcome to the forum :slight_smile:

If a Pixhawk is not showing up then there’s most likely an issue with either

  • the USB-A to micro-USB cable between the Raspberry Pi and Pixhawk
    • there could also be an issue with one of the ports
  • the firmware on the Pixhawk
  • the power supply to the Pixhawk
  • the Pixhawk hardware

Does it show up in QGroundControl if you plug it in directly to the topside computer? If not, try a different cable. If it does, try flashing ArduSub onto it through QGC.

If a different cable doesn’t help then there’s likely something wrong with either the Pixhawk microUSB port (which is by-passable if necessary), or the Pixhawk itself is fried. If the PWR lights are on then it’s at least able to receive power. If the B/E and/or ACT lights flash then the chip is working to at least some degree.

Hi, Eliot thanks for responding.

I have two BlueRov2s, when I tried connecting the topside computer of the working ROV to the ROV with this issue, I can see the camera stream on QGC, but QGC is still saying disconnected on the top. With this other topside computer as well, I cannot see pixhawk autopilot (bootloader) listed under the serial devices. What do you think might be the issue? Let me know if there is anything I can do to resolve this issue.

If you open the enclosure there should be a USB-A to micro-USB cable between the Pixhawk flight controller and Raspberry Pi onboard computer. If you unplug that cable and instead use it to directly connect the Pixhawk to the computer running QGroundControl, is QGroundControl able to detect it?

That’s what I was asking above - apologies if that wasn’t clear.

Hello Eliot, I have just now tried to connect the Pixhawk flight controller directly using the USB-A to micro-USB, but QGC is still unable to detect it.