Brand New Newton Gripper not Working and Causes Connection Loss

Hey all,
I recently purchased a Newton Gripper an began testing it however, after just one open and close the gripper stopped working. I then restarted the sub and then when I attempted to close the gripper again, QGroundControl lost connection, and the sub power draw dropped to 5v. I tried restarting the sub, re-connecting the gripper and restarting my computer, but every time as soon as I attempted to use it, the sub lost connection. Any ideas?

After further testing, the gripper only fails when the motor stall point is reached, but I was under the assumption that it was supposed to auto detect this and stop, not disconnect the rov.

Hi @hbillings, welcome to the forum :slight_smile:

Sorry to hear you’re having issues with your gripper.

The Newton Gripper is indeed supposed to automatically detect a stall condition and stop trying to continue beyond it. If the stall detection is failing then then it may be causing a high enough power surge to pull the battery voltage too low for the 5V converter to operate properly, in which case the control electronics will restart. That could also occur if you have a low voltage or low capacity battery to start with, but I’d expect then you’d have similar issues with running your thrusters, which presumably would have caused problems before you got the gripper.

I’d recommend you contact, and let them know the context as well as your order number (or at least rough order date). Assuming the gripper is faulty, they should be able to provide you with a replacement or refund as relevant :slight_smile:

Hey @EliotBR thankyou :slight_smile:
I haven’t tested the thrusters yet, just the gripper, but I am using a power supply at the moment, but I shall give them an email. Thankyou!

What kind of current capacity does it have? Most benchtop DC power supplies (assuming that’s what you’re talking about) aren’t intended for running motors, and the Newton Gripper’s peak current is specified at 6A - it’s very possible that’s the cause of your issue.

Yeah it was the power supply, it had the capacity to run it, I was just limiting the current. It all works now, thankyou!

1 Like