Home        Store        Docs        Blog

BlueROV2 no communication

Hi Jacob,

I have been encountering no communication with the BlueROV2 on 3 occasions using the same laptop. The symptoms are when i connect everything up as per normal, there were no video feed and displays " Waiting for Vehicle Communication " . The laptop does not commnunicate with BlueROV2. (Previous usage was able to connect up) All Batteries were fully charged.

What we tried to do was try restart both blue robotics and the laptop does not work, all the lights on the Pixhawk Fathom interface card was on and blinking.

Cables looks intact. Did some IP resetting. After we done what we could and still does not work, we pull the battery and shut down the laptop.

On the Next day we tired to connect to the BlueROV2 and it works! Have no idea why was it so and every functions was fine. This happened for 3 times for the past 2 month, as we were using for vessel inspection. Tried to ping the BlueROV2 but no feedback.

It happened again today so i was wondering could it be a hardware issue or software issue? Please advise.

We have a similar problem. Here’s the topic with the useful tips for debugging.

Hi I have the same problem how you fix the problem???

Yes. We swap the twisted pair cables.

Hi, can you tell me more specific which ones you swap…