Home        Store        Docs        Blog

BlueROV2 communication problem

Hi BlueRobotics,

a few days ago we took our new BlueROV2 on a first real test. It was working perfectly in our lab and when tested in shallow water (<2m). We were operating on a ship and just before our first scheduled dive BlueROV decided not to work. We weren’t able to establish communication. I have (quite a bit) experience with bluerobotics products at this point so it wasn’t any software/hardware setup issues. Topside computer was set at 192.168.2.1 address, firewall rule was added etc. I wasn’t able to ping Pi at 192.168.2.2. Several battery restarts did not help. At that point I had the ROV disassembled and checked, everything seemed fine. After some time I finally (by pure luck I guess) managed to access http://192.168.2.2:2770/system and restart Pi. After that we did one dive and everything worked perfectly. On our second dive everything worked fine just till the end of the dive when we had video artifacts, but no other major problems. Next day, on our final dive we weren’t able to establish communication and just gave up. Disassembled ROV again, restarted it several times, nothing. We had no leaks or any other issues.
Last couple of days I am trying to debug ROV in our lab. When Pi is connected directly to a computer via ethernet there are no issues at all, everything works perfectly. I have tested tether and tether spool connection from topside interface box to the Fathom X board on a ROV and everything is fine. Power and link active LEDs are ON, on both sides. Pi seems to be working normally since everything is working when tether is bypassed. So I have narrowed down the problem to either Fathom X interface boards on either end or USB to ethernet adapter in the FXTI.
Since I have no spare Fathom X boards nor USB to ethernet adapters, have you got any advice on how to test them?

Thanks! !
ipconfig|562x500

@sample,

I am betting that it is the USB to Ethernet adapter.

I assume that you are using a laptop/PC with Windows 10 installed?

If you are using Windows 10, when you get the problem again, go into the CP Devices and see if the USB to Ethernet adapter is functioning correctly or not.

Regards,
TCIII AVD

I’ve tested the adapter and it seems to be fine since I was able to ping Pi through usb-adapter-ethernet-pi connection. Communication through Fathom X and tether is not working. It looks like it’s the one (or both) of the Fathom X. Any tips on how to test them?

@sample,

If you have an Oscope, you can see what the tether output looks like with an input from QGC, otherwise the only other way is get a known good one and try a swap out to nail down the bad one.

Regards,
TCIII AVD

Are you using the ethernet adapter (FXTI) through a USB hub? We’ve found that some USB adapters do not work consistentley when running through a hub, especially if other devices are plugged in.

1 Like

Same here, nothing but problems in the hub with wireless, hard wired controller all good. I run my FXTI direct to the computer, a hub takes up the slack for other devices. The hardwired controller through the hub is completely happy. Wireless and things are bad.

@tciii Unfortunately for us we are the only one using BlueRobotics technology in a at least 600km radius. We might get our hand on the oscilloscope though. Thanks!

@spotxuv No, we are doing direct connection to a laptop. We have tested on our workstation in the lab, just in case, but no luck.

How long is your tether?

What are your upload / download speed when connecting with the web page?

Our tether is 300m on a spool.
I can’t measure speeds through tether since communication is not working and therefore I can’t even connect to the web page.
If it’s of any use, speeds when directly connected to Pi via ethernet are:
Upload: 80.923 Mbps
Download: 80.091 Mbps.

From experience, the BR2 struggles with 300m.

Speed when connecting the pc directly to the PI is not useful other than showing it works.

Mine is more around 95Mbps upload thought.

Have you tried connecting the fathom board directly to your computer’s ethernet port?

(Bypassing FXTI)

Have you tried connecting via another computer.

You might also want to bypass the 3 pin male headers and connect directly to the fathom topside and subsea.

Something else, and it might sound stupid, make sure you have the right pair connected topside and subsea. I once pulled my hair out during troubleshooting as I had connected the wrong pairs yet still achieved a certain level of communication. The Fathom tether is not shielded and allows cross-talk from one pair to the other…

Lastly, try a different pair.

1 Like

Thanks for the useful advice!

I have tried direct connection between the fathom and ethernet port, still no communication. I have bypassed the 3 pin male headers on both sides, the problem persists. I have tried every pair and made sure I have connected the correct pair - still nothing. Every combination was tried with direct ethernet link to the Fathom and communication over USB and nothing works. At this point I think it’s safe to say that Fathom X boards are the cause of the problem.
Unless there are any other ideas, I think I will just contact our BlueROV supplier and ask for a replacement.

yeah, I’m out of ideas.

Let us know if swapping the fathom-x boards solved the issue.

I had similar problems some weeks ago. Eventually narrowed down the problem to three intermittent connections. The rov and ethernet box does not travel well and the two pin connectors come loose. We have put heat glue on the three suspect connections and the problem seems to be solved. Frustratingly simple after purchasing a heap of spares.

I don’t know if you’ve seen this yet, and it looks like you’ve already covered some of the bases here, but here is our standard troubleshooting steps to take for no connection or no video: http://www.ardusub.com/troubleshooting/troubleshooting.html#no-telemetry-no-autopilot-connection

See if anything there helps. The nature of your problem (working to not working with no apparent changes) sounds like a transient physical connection (loose wire). Please make sure all of the connections are well seated in the rov and topside.

Make sure the ethernet port lights are active on the raspberry pi and topside.

Hi Jacob,

Yes, that was the first thing I did, unfortunately nothing helped.

Hi everyone! Quick update on this.

I have contacted our supplier (Nido Robotics) and they’ve advised me to measure the voltages on the FXTI. And so I did, I have connected our BlueROV and was very much surprised when it worked like nothing happened. Communication is working! When connected to laptop input voltage of FXTI is 5,15V and voltage of the Fathom X is 4,25 V (measured at the battery pins). When Fathom X is connected directly to the wall socket via 5V adapter measured voltage is 4,57V. Communication is working no matter how we connect the topside Fathom X.
Since I was able to, I ran the bandwidth test and the results are:

Upload: 10.542 Mbps
Download: 10.398 Mbps.

How are the results?

Any tips on how to proceed with this issue? Now everything seems to be working, but we don’t want to end up in the situation where we go on the field and are unable to finish our task because of the similar problem.
Can you think of any additional tests we can run now when we have communication working?

Thanks!

Hi @sample,

Sometimes a bad power supply of the Fathom-X can produce an inconsistent communication. With my laptop, I can see some lag in the video if I use one USB port, and everything goes fine with the other port… I recommend you to try with another port, another PC, and using a 5V power supply with more Watts. We will send you anyway a tested Fathom-X as a replacement. You should receive a mail from support@nido.ai during the day.

Best regards,

Enrique

1 Like

Yeah these results are pretty poor.

You are getting 5V on the fathom-X subsea?

Thank you Enrique!

@etienne On the subsea side Fathom X is powered by the battery so I am reading battery voltage (15-16V) at the battery pins.