Home        Store        Learn        Blog

Can't connect to my rpi 3B

Hi!
That is my first time using the BlueROV2. I have updated the softwares and now I am in the step where we need to connect to 192.168.2.2 from a browser. The problem is I get this message on my rpi :

So, I would be happy, if you have any idea about what’s going on with my rpi :frowning:
Thanks in advance :slight_smile: and have a good easter weekend

Hello @navylos_ear you had some answers and help here, but they were misguided and missing the root cause of the problem. So I have deleted those posts to clear the confusion.

To be clear, you are having issues communicating with the raspberry pi over the network (cannot access http://192.168.2.2:2770 through the browser), so now you have connected a keyboard and a monitor to the Pi to troubleshoot. The messages that you see on the monitor are from the boot process, and they are all normal, and not the cause of the network problem (even the lines that say error and exception, the pixhawk autopilot connection is ok and it should still work).

What you need to do is verify your network configuration and communication. Your computer network is not configured correctly to connect to the raspberry pi.

Please carefully follow these troubleshooting steps here, which should solve your situation. If you have a problem with these steps, let us know.

Hi Jacob, thank you for your answer, however I have already followed these steps, this is what I get when I tried to ping 192.168.2.2:


ping_19216822

I changed the ethernet cable to check if it comes from here but have the same result…
turn off my firewalls and reboot my laptop, have the same result…
Here is my QGC config too :

I’m really runing out of ideas haha :cry:.

Ok, so you are in an interesting situation. The output of ipconfig is showing the correct configuration for the network, and indicates that you should be able to ping the ROV. However, the ping fails.

Please check for me that the lights on the ethernet port connector are illuminated on the raspberry pi and on your ethernet adapter. If they are, then the problem is probably in windows.

I have seen situations like this in a couple of cases in the past, and the only solution I found was a bit extreme - is to reset windows networking configuration. You will need to set up any wifi and things like that again if you do this, but I think you should try. https://www.howtogeek.com/265870/how-to-reset-your-entire-network-in-windows-10-and-start-from-scratch/#:~:text=On%20the%20Windows%20Settings%20screen,the%20“Network%20reset”%20link.

I have checked the lights on the ethernet port of the raspberry pi, it’s blinking, for the ethernet port of the adapter you mean, the one on the fxti :

, it’s blinking too :slight_smile:
So I’ve tried to reset my network and have the same results :frowning:

I’ll be back tomorrow Jacob, hope we’ll find the answer :slight_smile: I still have hope!
Have a nice day!