Home        Store        Docs        Blog

ArduSub v3.6.0 Release Date?


(Ferit Çakıcı) #1

Is there a planned date for the stable release of ArduSub 3.6.0 or any newer version than 3.5.3?


(Jacob) #2

There is currently no release date set for a 3.6.0. Why you are interested?


(Ferit Çakıcı) #3

Hi @jwalser,

I am currently experimenting on speed/power tradeoff of a ROV. Since I cannot change the pwm limits of esc commands on ArduSub v3.5.3, I change ESC settings instead. And changing ESC settings requires opening electronics bay, which is very time consuming. Currently ArduCopter v3.6.5 and ArduPlane v3.9.5 supports DShot and BLHeli Pass-Through features, which allows changing ESC setting through Pixhawk.

I see that the current activity in the development of ArduSub firmware takes place under ArduPilot on Github. I am anxious to benefit from new features of ArduPilot Libraries on ArduSub, so I am wondering if there will be a new stable release soon with new features.

Best wishes.


(Jacob) #4

Since I cannot change the pwm limits of esc commands on ArduSub v3.5.3

You should be able to use MOT_PWM_MAX or SERVOn_MAX to accomplish this.

Right now we don’t have any timeline for moving to a 3.6 and adding dshot support (there are currently a lot of limitations with dshot + ardusub, and it will be hard to support and explain). I understand you want to use blheli passthrough, you may try to use the master/development build in the meantime.


(Ferit Çakıcı) #5

I tried MOT_PWM_MAX and SERVOn_MAX parameters without any success for “ArduSub v3.5.3”. Motor Servo output PWM ranges are stuck between 1100 and 1900, no matter the values of the above mentioned parameters are. Is there something I am missing?

I tried installing ArduSub v3.6.0dev from latest release. Pixhawk keeps resetting itself due to IMU errors. Which dev build should I install for Pixhawk 2.4.8?


(Ferit Çakıcı) #6

Hi @jwalser,

I have designed a system that runs ArduSub_v3.5.3.px4 (Nuttx) on Pixhawk, connected to RasPi with 0.0.16 companion computer image. I installed a Serial-to-Ethernet converter to Telem2 of Pixhawk, which allows me to change BLHeli32 ESC settings through BLHeli32Suite program, when the installed firware is ArduCopter_v3.6.5.apj (Chibos).

Only problem left to make this system operational is that I cannot change firmware from ArduCopter to ArduSub and from ArduSub to ArduCopter using Companion Web Interface. I believe the problem comes from different bootloaders used by Chibos (ArduCopter) and Nuttx (ArduSub). Although I can change between ArduSub and ArduCopter Nuttx builds, it does not help since “BLHeli Pass-Through” feature is only supported for Chibos builds.

Can you think of a solution for this problem?
Is there any chance of moving to Chibos for ArduSub firmware?


(Jacob) #7

Can you think of a solution for this problem?

I am not aware of a solution for you right now. You may try an arducopter build after dshot support, but before apj/chibios. The real solution should be to use the intended parameters that I mentioned, but alas, I have confirmed there is a bug here: https://github.com/ArduPilot/ardupilot/issues/9830

Is there any chance of moving to Chibos for ArduSub firmware?

Yes in the future, but there is no date set.


(Ferit Çakıcı) #8

I have tried almost all build options that seems logical to me with no success… Then I will have to wait for the Chibos build of ArduSub… Thanks @jwalser