ArduSub is v4.0.1 support for Pixhawk

I saw the older post on support for pixhawk 4, but that was when ArduSub was as 3.5. Does the current version of ArduSub support Pixhawk 4?


1 Like

Hi Joe,

As per the ArduSub docs (see the “Supported Hardware” section on that page), ArduSub is officially supported on only the Pixhawk 1 (PX4-v2), but it may also work for some/many of the other boards that ArduPilot can run on. There are pre-built binaries for various different boards here, but they’re auto-generated so we can’t guarantee that they’ll work.

Thanks Eliot, I cannot find any vendor that still sells the Pixhawk 1, other than cheap import models. They indicate that that version is discontinued. Blue Robotics only sells the whole kit. Currently I do not need the Fathom-X Tether Interface or the PI. Do you know where I can purchase a Pixhawk 1 (PX4-v2). The link you sent me indicates a security risk.


Pixhawk 1 is unfortunately past its End of Life so can’t be made anymore, which means it’s generally only sold as part of kits that require it, out of previously bought stock. Understandably that’s frustrating for everyone, and the Blue Robotics team is working to make an alternative board available with proper future support and an improved feature set.

In the interim, if you’re unable to obtain a Pixhawk 1 we expect that the Pixhawk 4 is likely the next best thing. I asked internally and was told we haven’t officially tested with the Pixhawk 4 (hence it not being in our confirmed working list), but because it’s intended to be basically a drop-in replacement it should likely ‘just work’ with ArduSub. The main components of “we don’t support it” are basically

  1. our current documentation is geared to Pixhawk 1, and
  2. the Pixhawk 4 has some additional features that aren’t implemented in ArduSub, so while ArduSub should work on it, it might not be able to make use of all the hardware that’s actually there (e.g. a couple of extra auxiliary IO ports that weren’t present in Pixhawk 1)

As a note, @hydropumpon was recently asking about adding a leak sensor to Pixhawk 4, so perhaps they can confirm if it works for the rest of ArduSub :slight_smile:

Yes, unfortunately the ArduPilot pre-built binaries page is only available through http, not https, so it’s unencrypted. That’s much more important for sites that you actually have accounts with and whatnot, but it’s still not ideal.

https became the de facto standard within the last several years, because it’s better for basically everything, but some sites are yet to update to it. The whole internet used to use plain http, so it’s not like every http site causes a guaranteed virus download or anything, but browsers now warn about it because it is technically less secure (higher risk that something bad could happen), and the warning is something of an encouragement to website maintainers to update their pages.

@EliotBR @jpitz Hello guys. Yes, i can confirm, that ArduSub 4+ is working on Pixhawk4 fmuv5 board (At least motors (but with uavcan), i2c external sensors, camera, gripper, lights, battery charge viewing and etc). Most functions are working from the box, but some of them need some changes (with wire connection or changing the Ardupilot code).

We are currently waiting compound to dry, and we will start water tests. So i will update the information about stability later.

PS. and sorry for late reply.


After doing some tests in the pool, i can confirm, that ardusub is working good on pixhawk4 fmuv5 board.


Hi @hydropumpon!

Would you be able to elaborate on what changes were required to integrate with the Pixhawk 4? I haven’t seen many others posting successful results, which is surprising with the Pixhawk 1 reaching EOL. I’ve had mixed results with the auxiliary servos, but no luck with main motors outside of QGroundControl’s setup tests. If y’all have worked with/had to make changes to Mavlink interfacing that would be extra valuable to know.


Hi @droneswithgooglyeyes, welcome to the forum :slight_smile:

We’ve just released ArduSub 4.1 as the new stable, which adds support for the Pixhawk 4 and our new Navigator flight controller. There’ll be a post about it in the next couple of days.

Hello, sorry for long time no reply. I almost didn’t change anything in Ardusub for pixhawk4 for simple motor working. As i remember, to make it work, i’ve just changed the ROV structure accordingly to my setup and setup required amount of drives enabled in QGC. And motors connected not by CAN spins well. Then i’ve just changed some code to enable CAN drive packets transmitting.
Do you mean that you’ve connected motors, flashed the pixhawk and motors are working only on motor setup page and don’t work using controller?

Hey @hydropumpon, no worries at all. This post helped get the motors running with joystick controls. Now I just need to revert some parameters to our specs to be up and running. We’ve had some success with both v4.1 and v4.2-dev of the firmware.