Where is the default gateway set in BlueOS?

  1. We’re trying to re-IP but need to understand where/how the default GW is set.
  2. When we change the IP via the web interface (static IP), there doesn’t seem to be a place to put any advanced settings like subnet mask or default GW.
  3. When we reboot up, there is no default GW set (as seen by route cmd from ssh session)
  4. Looks like none of the standard Linux places have the IP settings — where does BR set the IP?
  5. We see the IP itself in /root/.config/blueos/cable-guy/settings.json (but that has only IP, not netmask and not default GW)
  6. Even tried hacking a startup script to add default GW but does not seem to hold — unclear if the docker containers are doing their own thing

Question: need help on proper way to set default GW on the pi.

Hi @hube268,

I don’t have experience with network gateways, and am happy to bring this up with the software team if it’s relevant to do so, but I’m curious what the intended purpose is here - the latest BlueOS beta releases now support network priority selection (while in Pirate Mode) by clicking the network icon in the header bar, so perhaps that will solve your issue:

Hi Eliot, I am also inexperienced with network gateways, but my understanding is that the problem is the network we are connected to with MBARI does not support DHCP and so the gateway is not automatically assigned like it would be normally so the there is no route to the outside internet and thus we cannot make our connection to the ROV.

I have checked out Pirate mode but my pirate mode looks a lot different than your screenshot. I do not have the globe icon. The “DNS configuration” tab also looks interesting but is unavailable for me. I’m using this version:

Version: tags/1.0.1-0-gbc26236 Build: 4/6/2022, 3:04:28 PM

What version is in your screenshot?

That’s the 1.0.1 stable version - I was talking about the 1.1.0-beta versions (beta.27 specifically), which can be updated to while in Pirate Mode.

If you’re not comfortable running beta software we’re expecting to release 1.1.0 as stable within a couple of weeks, at which point the 1.1 documentation will have been fully updated with the latest changes.

1 Like

I changed versions but the additional settings did not solve the gateway issue. However, I did find this forum post which seems to have solved it:

1 Like