Video not available

Good day,

One month ago we had issues with video streaming on our BlueROV2.
After having tested all the connections including tether and ethernet plug (in addition to the Raspberry, phatom X, the camera etc.) we decided to buy a complete new electronics to solve the problem faster.
We assembled everything, formatted the PC, reinstalled Windows 10, reinstalled Qgroundcontrol and followed all the instructions provided by Bluerobotics. When we turn on the ROV we are unable to view the video stream. The telemetry is transmitted but the same “No video available” message always appears in QGroundControl.
We have tried to exclude the tether by directly connecting the ROV with the PC station using another ethernet cable, but the same message always appears.
We tried also the camera on the PC and it works.
It’s really strange as by fitting the new electronics we completely reinstalled everything but it seems to be the same problem we had with the old electronics.
If anyone has had a similar experience I would be grateful if he could help me.
Thanks in advance!

Did you check my thread? Here is the link. I also got this problem after the retrofit tutorial and I think I might had before as well, in the last time I tested with the old companion. Did you try to reduce the resolution? Please check if you had a similar problem with the camera after this. I put on the post a lot of possible fixes, none worked for me, but maybe they work for you.

Hi Matosinho,
Many thanks for the suggestions but we already tried everything.
If you or someone else have other solutions or suggestions…
Thanks again!

Some tip

Old page for troubleshoting, scroll down to “No Video”

Resolution of camera AND screen should be set to 1920x1080

If you still have a SD card with old companion system;
you could boot raspberry on that and check if video works.
/ Bo

@Boko thanks for the suggestion of the troubleshoot, but at least for my case all the solutions mentioned there didn’t work, I believe @UBICA tried the same. I’ll give it a try on the old companion system to check if the problem is there as well. Thanks.

Thanks Boko for suggestions but we tried all the solutions and they didn’t work.
We are now in contact with Bluerobotics support. Let you know if we solve the issue.
If there are other suggestions…
Many thanks

Nice! Please if you find the solutiuon, could you share it here? Probably we have the same problem.

Hello again! Could we centralize the comments regarding this topic in the @mdares post? Here it is: