Vertical Thruster with Pixhawk

Hi, So i was working on my ROV using pixhawk through BlueOS. I’m using the Vectored-6DOF frame. I was wondering if I can move my vertical thrusters (5,6,7,8) in both directions? I was not able to till now. Yes, I’m using BLDC motors with bidirectional ESCs. I have checked all the pwm limits as well…

Hi @Emaxad -
Yes, bidirectional ESCs should support the vertical thrusters operating in both directions - this allows the ROV to ascend and descend. Are you saying that didn’t work before, and does now, or the opposite?
What version of BlueOS and ArduSub are you using?

Hey @tony-white
So right now, I’m using BlueOS version 1.2.6 - the latest stable version. My vertical thrusters are only operating in one direction at the moment, which is to descend only. I have tried looking through multiple settings on QGroundControl and still couldn’t find any option to enable ascend and descend for vertical thrusters. Any idea why? My QGC is version v4.3.0

That’s very unusual! Are you using the standard Blue Robotics Basic ESC?
Have you placed the vehicle in water and attempted an automatic thruster direction calibration?
There isn’t an option to set this, as it is the default behavior. You could monitor with the QGround Control Mavlink Inspector what the Servo channels are outputting when you try to ascend - you should see the PWM values change from the default neutral 1500…

No, we arent using standard blue robotics ESC, but cheaper 30A bidirectional ones. We used the mavlink inspector as you said and the horizontal motors (1,2,3,4) give proper pwm values for all other movements, but vertical motors (5,6,7,8) start at 1500 and doesnt go below that. Only goes above it. I even calibrated my joystick multiple times and still the vertical thrusters start at 1500 and dont go below it when i want to ascend. I also went through parameters and max is 1900 and min is 1100 for all motors.

Hi @Emaxad - if your 1,2,3,4 motors are reversing properly, I would recommend (temporarily) connecting your 5,6,7,8 ESCs to these channels to verify they are capable of going both directions. I would suspect you alternative ESCs are the root of your issue…
Have you verified in the Mavlink Inspector that you are sending signals both above and below 1500 to these servo channels?

Hi @tony-white, on running the motors as said they are reversing properly. All the ESC’s are of the same brand. In Mavlink Inspector the vertical thrusters are not going below 1500. They are starting from 1500 and move up to 1900. They don’t go below 1500. This happens with only channels 6,7,8,9.

Tried this as well, and found out its not an ESC problem… checked pwm and it showed signals go above and below 1500. Only for Servo5,6,7,8 they start from 1500 and only go above.

Welcome to the forum @Emaxad and @mahedubai :slight_smile:

I haven’t seen this behaviour before, but the only causes I can think of would be

  1. the inputs the autopilot is receiving from the joystick / control station software, or
  2. the input or output handling parameters configured in the autopilot

Some questions to clarify the situation:

  1. Does your control station software show your throttle joystick going both above and below the center point?
  2. Have you configured throttle input options in your control station software that disable negative thrust or set the bottom of the joystick range to be the zero point?
  3. Have you tried resetting the autopilot parameters?
  4. Are you able to get values below 1500 in a motor test (in either BlueOS or QGroundControl)?
    • If yes then it’s likely a joystick or RC1/2/3_MIN/MAX parameter issue
  5. Are the vertical motor outputs limited to 1500+ even when trying to pitch and roll (not just vertical translation)?
    • If it’s only during throttle inputs then it’s likely a joystick or RC3_MIN/MAX parameter issue
  6. If it’s confirmed to be an output issue then check the SERVO5/6/7/8_MIN/MAX and the MOT_PWM_MIN/MAX parameters

If those ideas don’t help you to resolve the issue then please provide:

  • The software and firmware versions you’re using (ArduSub, BlueOS, QGroundControl/Cockpit)
  • The joystick model you’re using
  • A .params file of your autopilot parameters

so we can take a look and potentially try to replicate the problem.

Hello @EliotBR!

  1. Yes, when in Joystick section, I’m able to see my throttle stick go above and below the center point.
  2. I do not seem to have a option to disable negative thrust in my joystick setup.
  3. I have tried doing this multiple times…
  4. Yes in motor test, i can go above and below 1500 for the vertical thrusters.
  5. I have not tested for pitch and roll yet, going to do that soon.
  6. Checked Servo5/6/7/8_MIN/MAX which are set at 1100 and 1900 respectively with 1500 being the trim.

I have attached required data:-.
Firmware Version - Ardusub 4.1.2
BlueOS Version - 1.2.6
QGC Version - 4.3.0
My joystick is Logitech 3D Extreme Pro

I have attached my .params file as well, for now what I have done is changed the trim values for Servo5/6/7/8 to 1200 such that I can have ascend and descend.
rov.params (25.7 KB)