Vacuum pump Issues...Huge Leak?

Hello Everyone!

As field season is starting for myself and my crew, we plan on getting our Blue ROV2 out in the water doing dives. In prep for this season we have begun bringing out our ROV. Over the past two weeks, we have had significant issues passing and performing a vacuum pressure test. Around two months ago a pressure test was performed just because the ROV had been sitting in storage all winter and it passed.

Since then we have not been able to achieve a good test. Every time my crew has gone to test the main watertight enclosure our pump cannot get past the zero section on the hand pump, and cannot retain any pressure at all.
When using the pump on the battery enclosure it can build up a little pressure but it will all be released in less than a minute.
We have tried replacing the pump, and we have thoroughly looked and checked at all screws, seals, o rings, and possible places for a leak to be. We are truly stumped as to what the issue could be. (we have also done tests and the pump seems to hold pressure fine with just a cap on the end).
This leads us to believe this issue isn’t a leak but a faulty pump or entry point.

A thought we had is that possibly there’s an issue keeping a seal between the pump’s entry point and the enclosure, but there seem to be no visual issues there.

We are wondering if anyone has any possible answers or solutions to this persistent issue… Hoping to get our ROV in the water as soon as possible but this pressure issue is keeping us from doing a test dive. We aren’t sure how to rule out if it is a leak or not and do not want to risk getting water inside the chamber. Are there any other ways to test for air leaks?


When checking the Orings did you clean and re grease?

Are you vacuum testing both enclosures at the same time?

You may have tried this already but I found that my ROV was failing because the vacuum pump tubes were leaking around the ends of the tube where they connect to the pump or the connections/adapters. They had lost elasticity slightly so I trimmed an inch or two off the ends of the tubes and reassembled it. That worked in my case… I realise you’ve tested the pump separately but may be worth a shot if you’re still stuck

Otherwise I sometimes (cautiously) apply slight positive pressure to the ROV (using the pump, via the vacuum test penetrator on the electronics enclosure only) and slowly fill the bath whilst checking for bubbles around all seals, cables, thrusters, lights etc as the water level rises, to help locate leaks. If you do this make sure the battery is removed. I use a GoPro to get a close view underwater. Also avoid pumping in too much air as the end caps could pop off or the vacuum connectors - just a couple of pumps every now and the is fine. If you are desperate and considering this test it may be worth removing the electronics tray from the main enclosure first to avoid damaging your electronics (removing the electronics is not something I usually do but probably best if it’s a big leak)

1 Like

Thank you! I think we have determined that it is an issue with our o rings - We decided to replace a couple and they seem to be smaller than the original ones - thus causing the ROV to not have an actual seal…

Glad that the issue was a simple fix as opposed to an actual huge leak. Thanks for these tips and tricks!