Home        Store        Docs        Blog

Using a power pack for topside Fathom x


(Terry Eglinton) #1

Hi,
My laptop is very power hungry, (MSI gaming laptop). Tried most things to reduce the power consumption, and I cannot source a power pack which will supply enough current to charge the laptops battery. So, instead of plugging the topside fathom X into the laptop I have experimented with using a separate power pack for the fathom X. All worked well, thruster’s, lights and video. Only one issue, when recording video, the icon flashes but only a still picture is recorded.
Any thoughts anyone?


(Kaos) #2

@Teggles I have been using a usb battery bank for the fathom x for a long time without problems. I use a deep cycle battery for keeping the laptop charged up thru a 12vt charger which will last 24hrs at least.
I would check that your power source for the fathom x is delivering enuf volts


(Jacob) #3
  • What version of QGC are you using?
  • How large is the recorded file?
  • Can you upload a short ‘clip’?

(Terry Eglinton) #4

Hi Jacob,
I am using QGC v3.2.4 Rev 4. I have changed the video format to mp4 and it works! But in doing so I have lost the camera tilt function. Can’t think how the two are related but the error message on the consol is:
at qrc:/qml APM camerasimplecomponent.qml:176: ReferenceError_mountdefaultmode is not defined.

The next line is the same except for - qml:181:

Now default mode is retracted (and always has been) and the type is servo.

I have changed controller, moved the servo power off, when power is applied the servo moves to its last known position and is then locked solid.

Very strange!


(Jacob) #5

The mode should be ‘RC Targeting’, this is your problem. I don’t know how it changed, and I doubt it ever worked in ‘Retracted’ mode. You can reload the default parameters from the Frame menu.

The qgc log looks like you might be using an old version of the ArduSub firmware. You can check your current version in Vehicle Setup->Summary->Frame->firmware version. The latest is 3.5.2.


(Terry Eglinton) #6

Hi Jacob, RC targeting has cured the problem, thanks. From the frame menu, trying to download the default parameters brings this message:
Parma file github Json download failed. Error during download. Error 6
Any ideas?
Summary/frame/firmware version is 3.5.2.
I hope I have’t made you work the holiday weekend?
Happy Easter,
Terry.