USB/IP extension

Hello everyone, I come looking for your help, I have been trying to use the usbip extension for days, but I can’t get it to work, at first I thought it was my client’s problem, but then I noticed some problems (attached images) when following the instructions that They appear in the same extension, my theory is that no server is actually being created on the raspberry, I would appreciate any help or guidance


Hi @seba -
Sorry you’re having issues! The command you tried to run at the terminal isn’t going to work. If you want to view the logs from the USB-IP extension, you can click the “View Logs” button under the installed extension.
I’ve not tried USB-IP, but had great and easy success with VirtualHere, which uses USB-IP under the hood. I would recommend giving that a go!

Out of curiosity, what USB device are you trying to forward to your topside computer?

1 Like

Hello Tony, when the extension is like in the image it does not allow me to “View Logs” is there any way to repair the extension? I tell you I am implementing an imageex sonar plus a complementary IMU, I tell you that I did try the VirtualHere extension and it It worked very well but the free version only allows you to link one device at a time, and the truth is I would pay for the full version, but personally I think their licensing policies are stupid, I prefer to find out how to solve the usbip extension hahaha

Hi @seba,

I just updated the USB/IP extension, it is still somewhat rudimentary, but it should work now.


Hello, I have tried the modification and it works well for me, only with the difficulty of being able to share 2 devices simultaneously, the raspberry detects both USBs but, when I search with the command usbio list it does not appear, (I clarify that at one point I managed to do it , but I couldn’t replicate it) any suggestions? Any help would be greatly appreciated

Hi, can you run sudo usbip list at blueos`s terminal? use red-pill to run it at the host machine.

Hello, thank you for your help, I did what you asked me and this is what I got (photo attached) and everything looks good, I tell you that the only way to be able to have 2 simultaneous devices is to physically connect a device to the raspberry and link the device in usbip, then connect the other device and link it in usbip, but clearly this is not viable in practice where I will not have physical access to the raspberry, I am currently reviewing the client, perhaps there is a problem there.

yes, that’s a bug. my fault for only testing with one device while updating the extension to use our commander service instead of direct ssh. from the screenshot, a .split(\n) needs and extra \.
I’ll fix this up in the next couple of days.


This should be fixed in the new 1.0.3 release =]

1 Like

Thank you very much William Galvani, I will be attentive to the publication of version 1.03 :slight_smile:

it is up in the store now =]

1 Like