Usb/Eth HUB Connection

Hi everyone !

We are using waveshare usb/eth hub in our system. When we connected our sonar to usb/eth hub’s ethernet port the data flow gets stuck at regular intervals.

When we connected to ethernet switch it works.

Is there any solution about usb/eth hub problem ?


1 Like

Hi @ugurdemirezen,

That sounds like either an issue with the hub, or just insufficient bandwidth on the connection you’re using for what you’re trying to send through it.

Can you explain a bit more about your setup? I regularly use a USB/Ethernet hub on the topside and don’t have issues with it, but in that case my Ping360 is connected via the ethernet switch in the vehicle, and the hub uses USB-C to communicate with my topside computer so there aren’t particular bandwidth limitations there.

If you’re trying to use a hub inside the vehicle and you’re using a RPi 3 then the hub will be limiting the data throughput to USB-2 speeds (because RPi3 only supports USB-2). In addition, if there’s anything else connected to the hub then it will be switching between each connected device to get its data through, which could explain some regular “getting stuck” depending on how frequently and for how long it’s occurring.

1 Like

I had a similar problem and it disappeared after replacing another USB-Hub.

1 Like

Thanks a lot for your answer ! We used a simple ethernet switch and it worked.

Thanks again Eliot you are helping us a lot! We switched our BR switch to basic ethernet switch and it worked well.

But we still have some interference on our video stream. We are using BR low-light camera. But we extended the cable and we wrapped it with aluminum foil to prevent from interference. Even so we have some interference.

Also when we connected the camera directly to computer there is not any interference.

Could you give us some advice on this, please?


USB signals can be finicky, especially if the cable twisting is interrupted or the shielding is inconsistent/insufficient near strong noise sources. This previous comment is relevant:

If there are other devices on the USB bus I’d suggest trying with only the camera connected, which should help identify if it’s a powering issue, and then if that’s fine try to see if moving the cable away from ESCs and other noise sources is helpful :slight_smile: