USB Camera Unexpected Failure

@EliotBR I found your comment here about USB camera issues. We have been trying to troubleshoot three of the Low Light Cameras appearing to have failed just recently on a new build and the cameras do appear to be dead. Nothing fancy - standard build. BlueOS 1.0.1 / Camera HD Low Light. If we need to change firmware it would be helpful in our work.

@Ben595 if you haven’t already, please get in touch about the failed cameras via our support email (

On the firmware side, we’re still testing the updated firmware to make sure it doesn’t cause any unexpected issues with the vehicle operation, so haven’t yet made an official release for it. Our current testing process is to

  1. Reset the Raspberry Pi’s bootloader
  2. Download and flash on the BlueOS 1.0.2 Candidate image to your Raspberry Pi’s SD card

EDIT: I’ve been told that existing users should be able to fix this via the BlueOS Terminal page by running red-pill (to access the underlying operating system), then running sudo rpi-eeprom-update -a -d (to fix the Pi firmware).

We’re planning to add an update button for that to the interface, but haven’t got around to it yet.

Thanks Eliot! Appreciate the recommendation and we will do both today.

1 Like

Eliot - We updated the firmware to 1.0.2 and had success today. All three new cameras are working on this ROV. Appreciate the help.

1 Like

Hello Elliot!
I am also having trouble with cameras on Rpi4/Navigator with BlueOS.
The camera works for some seconds, then it becomes unstable, with video going on and off.
Also, on the Streams page, I see the stream changing between “Running” and “Not Running” every few seconds.
I connected it directly to a computer, and it worked fine.
I changed cameras, changed the whole electronics, and the problem is still here.
I also tried the procedure you described, with no success.

Is there anything else I could try? Is there any newer version cameras that works?
Thank you

Hi @fhmrocha

Although you’ve tested it on your computer, we are not sure whether this is a hardware issue or something within the software system. To investigate it I’d need your help to get some specific data from your ROV, and I’d also ask you to try BlueOS 1.1, released just this week.

The data I need is:

  1. Your BlueOS version. You can copy the text at the bottom of the left menu.

  2. Your system logs. You can reach the download button after clicking on the gear icon in the left menu.

  3. The kernel messages from our System Informations page as a file here? The video below shows the steps to copy it:


I hope I can better help you after reading those logs,


1 Like

Hello @joaoantoniocardoso !

I updated to BlueOS 1.1.0, and had the same result: video going On and Off every ~5 seconds.
Here follows the kernel log:
kernel_log.txt (2.5 KB)

And here a link to the system logs:!Aqa4XoPIPHI7g6oNUro6qwM1YaCMHw?e=W2PXYv

Please let me know if I can provide any other information.

Hi @fhmrocha,

Thank you for the logs. From the messages I can see that the GStreamer is having trouble gathering the data from the camera, and from the kernel logs it seems to be an issue related to the USB.

Since the camera is working on another machine, we came up with two main ideas:

  1. There’s an issue with the USB connection between the camera and the Raspberry Pi, which might be something related to energy quality or electromagnetic interference. You can try to:
    a) switch the power supply or disconnect the ESCs or other loads from the battery or 5V power supply, just for troubleshooting.
    b) switch the USB port of the camera
  2. There’s an issue triggered only with H264, which would explain why it works on your computer but not on BlueOS. Can you try to stream a MJPG stream using RTSP and receive it on your QGC?


Hi @joaoantoniocardoso !
I don’t think it is related with connection problems (like faulty cables) as I tried different cables, and I can see the same behaviour in 2 different ROVs.

We have 2 older systems (Rpi3 + Pixhawk) and video works as expected on them.

1 - I tried all the USB ports, and have the same problem on the USB3 (blue ones), and the othes doesn’t work at all.
I also tried disconnecting everything from the Navigator, and power the RPi from the USB-C connector (as in the picture below), and had the same result.

I also removed the Navigator, leaving only the camera plugged on the USB port, and it showed no video devices on the Video Streams page.

2 - I’m not really sure on how to do it. Can you provide more details?

Thank you!

Good, assuming you have tried the same cameras in another Raspberry Pi and got the same results, then we know the problem is not with the Raspberry Pi or its power supply, cables, or influence from the circuitry around it.

2 - I’m not really sure on how to do it. Can you provide more details?

  1. Enable the pirate mode (it’s the robot icon on the top right)
  2. Go to the video page, you’ll then find a device that has MJPG format available instead of H264.
  3. Switch the UDP endpoint to an RTSP one. It will automatically suggest a valid endpoint.
  4. Try QGC as usual.


Hi João!

I tried switching to MJPEG stream and it showed the video on QGC, but it was very slow (about 1 frame per second), so it is not usable.
Here follows the kernel and system logs.
kernel_log2.txt (48.6 KB)!Aqa4XoPIPHI7hNI_VsjUdA5G9-LuMA?e=UAJIzo

Thank you!

Hey @joaoantoniocardoso!

Any news regarding this issue? My company needs to do some inspections, so we need the cameras working.
Thank you

Hi @fhmrocha, sorry for the late reply. I’ve analyzed the logs, and I couldn’t find anything to blame the software, so considering the kernel message we had earlier, I believe it is more likely to be some kind of hardware issue, might be the camera, might be the raspberry, might be a combination of factors, so I asked for our support team to contact you.



I’m having the same issue with my camera. How did they resolve the problem?

Hi Ryan - We’ve had some quality issues with our low-light USB cameras lately. If your experiencing camera issues it’s good to first test the camera by plugging it directly into a computer. The built-in camera viewer in most operating systems should recongize it and allow you to view the image live - if not, the hardware could be having issues. If that’s the case, please reach out to support@bluerobotics with the order # if possible. Thanks!