Trouble reading camera from USB-port

We are using a ExploreHD from DWE and it has worked earlier, but somehow now the raspberry won’t register that it is plugged in to the USB-port. We have since it work last, we have integrated a PCB and tried out some different code.
The connection through the board seems to be fine. When it is plugged into a laptop with the same wiring, the camera works fine.

The camera isn’t registered and can’t be found with “lsusb” while other components can in the same port. When looking at messages with “dmesg” and trying different ports, we get the following:

We are currently using BlueOS beta10 and Qgroundcontrol.

That UVC non compliance bit seems very relevant.
Is the laptop also running Linux?

I’d reach out to DWE and ask them if they have seen this before.

No, it’s windows.
But we have managed to connect to the camera now and have a live video-feed. It helped just enough to twist the wires a bit more. Although the connection is very unstable when we go through the raspberry pi and our tether of 30 meters at the moment. The video will flicker and cut of to maybe come back again. When connecting the same USB directly to a laptop, there’s less trouble.
We have tried shielding the camera wire to reduce EMI, but to no success.
It seems that the signal becomes unstable somewhere between the RPi and when it comes through the tether and Fathom-X topside.

Thank you for the help.

This is what the terminal tells us:

Hi @Nicklaslb,

Maybe try running a network test? If the camera is working fine elsewhere then perhaps there’s some issue with your Fathom-X boards or your tether. It may also be worth trying to test with a direct ethernet connection between the Raspberry Pi and your topside computer.

Alternatively there may be issues with the Raspberry Pi failing to provide sufficient power to the camera.

1 Like

We are in the process of intense report writing and have set a pin in the testing, but will pick it up again in January :smile:
Thank you for the responds!


I’ve run the network test and there’s no problem here.
I’m now connected directly to the Raspberry Pi through ethernet and get this slightly different error.

The camera works perfectly when connected to the computer with the same connection.
There doesn’t seem to be any trouble with voltage drop.
I’ll write DWE about this as well to see if they have encountered this problem.

Thank you in advance.

Through a lot of tinkering, trial and error, and retries we have somehow made the camera feed fairly stable along side the other signals.
Thank you for your help in the process.

1 Like

Glad to hear you’ve managed to (at least mostly?) resolve your issue :slight_smile:

Am I correct in thinking that from your wording it seems you don’t necessarily know exactly what was wrong / how it got fixed? I’m curious if there’s anything in particular you tried that you’d recommend for others who have issues getting a new type of camera connected.

Yes that is correct, we are not 100% sure what exactly fixed the problem, probably a mix of multiple things.

First of make sure your camera connection(wiring and connectors) are solid! Make sure there is plenty of connection when soldering or otherwise connecting wires. Twist your signal cables thoroughly and make sure they are close together. Be sure that you have a steady 5 Volt power supply to your camera (measure this).
We have added ferrite beads to the signal cables (Rx/Tx) because we were worried about noice from batteries and other components in our enclosure in our robot. Although this probably didn’t do much of a difference. Good luck out there :slight_smile:

1 Like