Home        Store        Learn        Blog

Underwater GPS G2 web error messages / initial setup

We are working on setting up an Underwater GPS G2 with a U1 locator indoors.

During the process of setting up the G2 system/validating proper functionality of a cheap cabled Chinese sourced GPS extender, the GPS G2 web user interface was reporting that a GPS signal was not found. Initially we attributed this to errors in setting up the extender.

However when we tried to update our settings with a static GPS position just to try it out we received a “Failed to store” error message. And by using the browser debugging tools we could see a lot of 500 error messages. At that time we had to leave and hence was unable to restart the system to see if that solved the issue.

Due to the current Pandemic we are restricted in how much we can be at the office and while we are waiting to be able to test out more, I’m posting here in the hope that others might be able to help us out if this is a known issue/has happened with others.

Also: have anyone had success using cabled GPS extenders? We are 10-15m from the nearest window and in worst case scenario we hope to be able to get a GPS lock on the main unit and the U1 placed next to the window and then move them to the pool after initial GPS lock has been acquired.

Kjetil

A small follow up:

We where able to pin down the reason for the 500 (Internal Server Error) messages today:
This error occurs when the system is unable to get a GPS lock*. There is no reason for throwing a 500 error message due to no GPS lock, so this should be considered a bug to be fixed.

  • We moved the Pelican case with the GPS G2 electronics next to the window in the room we are using for testing, so we where quite surprised that we couldn’t get a GPS lock (GPS newbies). So there seems to be no way around for us but to drill a hole in the external wall and mount the GPS extender antenna outside.

This case is handled though the Water Linked support system, but i’ll clarify for others looking at this thread late:.

The Underwater GPS should be configurable and usable without GPS fix, but using the Locator U1 you will not get a valid position without GPS fix.

The 503 HTTP status code is used by our API to denote that there is no valid position available and is expected to occur if configured to use Locator U1 and the kit has no GPS fix. (I can agree that using a status code of “503 Internal server error” can be confusing in this case, but have chosen to keep this for backward compatibility with ROV vendors that are using our API)

2 Likes

Kristian,

Thanks for the follow up here and in the emails!

I’ll mark your reply as a solution (although more an explanation for why we saw the error messages).