Thrusters not running

Having an issue with the thrusters on our BlueROV2. When powered on and in the water our thrusters will not fire up or take commands from the controller. Our ROV has worked in the past and this issue presented itself out of nowhere.
We preformed a automatic motor test and all thrusters fire up and say that they are running fine, but when looking at the log we do get a message that reads “bad thrust read, trying to push the other way”.
(Picture also Attached)

The ROV also passes all the calibrations, and the controller is connected and enabled. When we arm the vehicle it beeps but no thruster movement at all.
We have tried looking for loose wiring within the ROV, we’ve also redownloaded QGC. We are fairly new the the ROV world so we aren’t sure where to go from here.

Hi @ruthduncan, sorry for the delay on responding to this.

From your screenshot it looks like the direction detection is completing consistently - I expect the “bad thrust read, trying to push the other way” messages are just logging while the detection tries to find the correct orientation for each thruster.

What kind of beeping is it doing? There should be 5 startup beeps from each thruster, with three rising in pitch to start with to indicate each of the thruster phases is connected to the ESC, then one longer low beep when the ESC is receiving a valid control signal, and a high one when that signal is set to “neutral” (1500).

Assuming the wiring is all as expected, does it help to reset the parameters?

If not, could you please provide the software and firmware versions you’re using (ArduSub, BlueOS / Companion, QGC), and confirm that they match our latest recommended versions?