Home        Store        Learn        Blog

Thruster issue pixhawk port

My #5 thruster has gone down, the issue is the port on the pixhawk. Has anyone has this issue and does anyone know if it could be softwear related. It’s only done one dive. The thrusters only have 1hr Max run time on them

Thanks Davie

Hi Davie,

I’m assuming this means

  1. the thruster was working on port 5, but isn’t anymore
  2. you’ve tried plugging the thruster into a different port and it works, and
  3. you’ve tried plugging something else (e.g. a different thruster) into your #5 port and it didn’t work

If it was working before and you haven’t been playing with custom ArduSub builds that could have disabled that port or changed what it’s used for then it’s highly unlikely it’s a software issue.

I’d recommend you contact support@bluerobotics.com to discuss a replacement/refund. You’ll want to link them to this thread, and ideally also let them know when you bought the pixhawk/ROV (order number is helpful if you’ve got it).

Hi Eliot.

Yes correct tried a knowing working thruster in port 5 and nothing. And also tried the original thruster that was plugged into port 5 and abs that works so it all points to the port.

I appreciate your feedback it’s been most helpful.:+1:

Davie

1 Like