Home        Store        Learn        Blog

Throttle doesnt work properly

I have a jetson nano and pixhawk 2.4.8 setup.But it seems that my motors doesnt respond to my commands properly because i have bluerobotics heavy frame setup.I’m trying to send 1600 pwm val to channel 3 (which is throttle) and i’m expecting motors 5,6,7,8 to work instead all 8 of my motors work can you help me please?

Hi @Baydarakci, welcome to the forum :slight_smile:

Would you be able to provide some more information about your setup and the code you’re running? It would be helpful to know which ArduSub version you’re using, along with the flight mode you’re operating in and the commands you’re using to control the vehicle.

The How to Use the Blue Robotics Forums post has a section on formatting, which includes how to post code in a code block :slight_smile:

I’m using V4.0.3 ardusub version and I have Vectored-6DOF bluerobotics heavy frame.It’s running with dronekit.When I look ArduSub RC channels ,I can see throttle from channel 3 so i’m expecting motors 5,6,7,8 to work instead all 8 of my motors work

My code:

from dronekit import connect
pusat=connect('/dev/ttyACM0',wait_ready=True,baud=115200) #connection 
pusat.armed=True #vehicle active
while True:
	pusat.channels.overrides['3']=1600 

I’ve encountered a similar issue previously, and found that

I suggest you try setting channels 1 to 6 to stopped (1500) before you arm, and see if that fixes the issue :slight_smile:


By the way, I wasn’t aware of dronekit-python. It’s apparently a wrapper around pymavlink that tries to improve the interface, and includes documentation. It seems like an interesting project, but the development/maintenance has mostly died out since 2016 (when 3D Robotics split from the ArduPilot project, and stopped producing open-source drones).