Sonar IP address confliction

I tried to use ping 1d sonar and ping 360 scanning sonar simultaneously by connecting to raspberry pi via USB.

However I cannot make a stabale connection to these sonar.
(I can make a stable connection to each sonar, when only one sonar is connected to raspberry pi.)

I think that the reason why the connection is unstable is
・these sonar have same IP address, because these are connected same raspberry pi (ping 1d sonar :, ping 360 sonar :

Do you have any solutions?

Hi @yuki,

It should work fine to use both of those on BlueOS. They’re presented on the IP address of the onboard computer (, because that’s the device that’s providing an endpoint to them. There’s no conflict between them, because they’re at different ports (9090 and 9092).

Which BlueOS version are you using, and how are you connecting to the sonars?
If possible please make sure you’re using our latest recommended software versions.

The Pings page (available in recent BlueOS beta images) should show where each ping family device is plugged into, along with its firmware version, and which IP and port it’s being sent to.

Some things to check/try:

  • make sure your software is updated
  • do a network test in BlueOS
    • if you have a low bandwidth problem then you may not be able to stream data from both at once
    • it may be worth trying with an ethernet cable directly from the onboard computer (Raspberry Pi) to your control station computer (topside), to see if the Fathom-Xs and/or tether could be the cause of the issue
  • check your power supply / battery
    • if you have low power, it may not be enough to power both devices plus the rest of your vehicle
  • if you have an Ethernet Switch in your vehicle, you can try using the Ping360 in the ethernet configuration

update from companion software to BlueOS - Stable 1.0.1 is done

The network test result is not good (pic1)

The next test is good by connecting directly from the onboard computer to topside computer.
It tells me that the issue from the Fathom-Xs and/or tether. (pic2)

enough power supply (pic3)
Screenshot from 2023-01-07 16-36-56

There is Ethernet Switch in my ROV.
Therefore should I try to use the Ping360 in the ethernet configuration?

Are you able to try the latest beta image (requires turning on Pirate Mode)? It has a Pings page that should show whether it’s detecting your Ping device(s).

Hmm, not sure what’s going on there. Is that behaviour consistent across multiple attempts?

Fair enough, or perhaps the Ethernet Switch.

You can do, but if your ethernet connection isn’t working properly then it’s not likely you’ll be able to communicate with your Ping360 in either USB or ethernet configuration. You’ll need to fix your connectivity issues first.

In Pings page, that show both devices.

I have tried several time, it happen everytime.

It means that problem happen between ethernet switch and topside computer not onboard computer and ethernet switch?

When I try to record both device data in the air, I can record.
However, underwater data record is ubstable.
I think that unstability is caused by DVL change valid/invalid and onboard computer has much data.

Ok, so the devices are at least working to some extent

Either of those is a possibility.

Ok, the main suspects there for me then are

  • a physical connectivity issue
    • e.g. if there’s a small break in an internal wire in your tether that loses connection when the tether is under tension during operation, although that would also cause issues with your video stream and general communications
  • a power supply issue, preventing the sonars from working properly
    • the 5V supply should be quite stable, so if this was the case I would expect it to mainly affect the Ping360
  • some electrical noise (e.g. from the ESCs) that’s interfering with the signals between the sonars and the onboard computer, but only happening when the vehicle is being controlled in the water
    • you could confirm this by holding the vehicle underwater while it is disarmed and seeing whether the sonar communication works as expected
    • there are some suggestions in this comment on electrical noise avoidance and mitigation

It’s unlikely the data amount is an issue, because the data rate from the DVL is generally quite low compared to the telemetry and video information.

You could confirm whether this is the issue by disabling the DVL and seeing if the problem remains.