Software Setup step failure: There is no data on the user web interface, only a white screen

Blank white screen. Anyone, any thoughts? Stuff I tried below…

Verified Good

  • Verified System Requirements: Windows 10 Enterprise 64bit, 16G RAM, i7 Processor Good
  • Verified Network Settings: Good (triple checked).
  • Verified Firewall Settings: Good (triple checked).
  • QGroundControl Software connectivity established. Can control motors, manipulate camera, and stimulate sensors.


  • BlueROV2 is out of the box (received 03/2024).
  • DoD secure facility, thus no Wifi or internet connection is available to the laptop we are using for setup.

Step FAILED - Troubleshooting Performed

  1. Performed Ping after each troubleshooting step below (steps b-h). Good. Communication hardware connections and main network setup are correct.
  2. Used two different laptops. Step FAILED same.
  3. Recycled power. Step FAILED same.
  4. Reset ethernet connection on Raspberry Pi. Step FAILED same.
  5. Reseated SD Card on Raspberry Pi. Step FAILED same.
  6. Rolled tether pins on Fathom X Tether Interface board. Step FAILED same.
  7. Internet Explorer browser. Step FAILED same.
  8. Edge browser. Step FAILED same.
  9. Tried clearing browser’s cache, and an incognito/private window. Step FAILED same.

Next Steps

  • I’m going to take the SD card home and flash a new image and install BlueOS. I will use these steps: Installation | ArduSub (

Setup References

  • Step FAILED Link: BlueROV2 Software, Computer, and Joystick Setup Instructions (
  • Step FAILED Description: Browser accessible user interface is not accessible (see attached image).

Hi @chejado -
Welcome to the Forums!
These are the correct instructions to follow to install BlueOS.

If you’re able to ping, then perhaps some firewall/security setting is preventing access from your DoD computer? QGround Control working while not able to load the BlueOS interface can sometimes indicate your subnet mask (on connected computer) is not set to …

Can you ssh (username pi, password raspberry) into the system?

Chrome is the recommended browser for BlueOS.

I’ll give it a shot on Thursday and let you know. Also, can you explain a case where I would need to use the “Manual Installation”?

Thanks Tony.

Hi @chejado -
Can you specify what about the manual installation description is confusing you?
" For developers with alternative hardware, or who would rather install over a pre-installed base operating system / image, BlueOS provides an install directory with utilities to help perform manual/software-based installations."
If you’re using default Raspberry Pi 4 hardware this is not necessary, unless you are developing a unique case.

Good morning Tony,

Appreciate the input.


  • I loaded the new image (stable version) V1.2.3 to the Raspberry Pi using these instructions. Booted up (audible noise) fine. Ping test fine. Launched in Internet Explorer. Same FAILURE.


  • I do not know how to ssh into the Raspberry Pi. I would need step by step instructions and all the pre-requisites/configuration setup defined. I am not network or hardware savvy.


  • I found under “SOFTWARE UPDATE”, step 2 here, it says ensure there is a WiFi connection (see below for quick reference).

    • STEP 2. “Navigate to in an internet browser (Chrome, Edge, Firefox, etc.) and ensure that the vehicle has access to a WiFi network. If a webpage is not found at this address, verify the network settings are correct. Troubleshooting steps can be found here.”


  • I do not have a WiFi connection. Nor do I have Google Chrome loaded on this standalone laptop. I am unable to get a WiFi connection in this secure space using this laptop.

    Because I cannot complete this part of the step - no WiFi access - I cannot confirm if having no WiFi access would cause this failure?

    However, because I imaged the most recent version at home and loaded it into the Raspberry Pi without WiFi access (04/12/2024) I will assume that is the intent of the step cited in the first and original post I submitted to the forum

Hi @chejado ,

are you able to open the browser’s developer tools to check the console? It’s likely that there is relevant information there. I’d try edge/firefox/chrome

Can you help me decipher what relevant information would look like Willian?

It looks to me that you are installing BlueOS but then trying to access URLs that are redundant now, were part of the old companion software but now superceded. The guides you are referring to are for the old companion software, not BlueOS.

Instead of browsing to

Just browse direct to in the web browser.

Correct. And I’ve done that as well.

I should have specified; that, out of curiosity I went back to the old instructions to see if any instructions were left out that might be relevant. Note I had highlighted what I was concerned about in bold. The “ensure that the vehicle has access to a WiFi network” was not included in the newer Software Setup instructions.

I am assuming that a vast majority of users have access to WiFi when setting up for BlueOS web user interface and I am a unique case.

My question to a user with WiFi access is: if you select Airplane Mode on your laptop, are you able to access the BlueOS web user interface through your browser? Or do you get a white screen like me?

Hi @chejado
Your computer only needs the tether based Ethernet connection to communicate with BlueOS. Too update BlueOS and install extensions you will connect the system to local Wi-Fi with Internet, but this is not necessary to simply access the web interface.
I would recommend cleaning your browsers cache or trying another browser to load the interface at, this assumes you’re able to ping the device at that address from your computer’s terminal. Please verify you’ve confirmed the subnet mask of your computer’s Ethernet connection as well.

You may want to verify the system is booting correctly, if the image is improperly flashed or corrupted the system may not boot. You can connect a monitor via HDMI adapter directly to the raspberry pi to do this.

Will do Tony.


  • Subnet mask Same FAILURE.
  • Cache, browsing history, etc cleaned. Same FAILURE.
  • Browse directly to Same FAILURE.


  • Connect a monitor via HDMI adapter directly to Raspberry Pi to monitor boot using these instructions for setup.

Any error could be relevant. these will show in red. Some of them are expected (due to how we check if some custom files exist), but the root of your issue should also be showing in there.

BlueOS should work fine with no internet access, as that is the case for many people using ROVs in remote locations


I was referring to strictly during setup. Which I would assume most users don’t setup in an area without Wifi. Tony confirmed that it shouldn’t matter during setup if I have WiFi or not. I’ll add looking at my console the next time. Thanks.

Definitely understand the ROV will operate in a remote area - that’s me too! And thanks for the prompt replies btw.