RFD's Communication Issue


I configured the 2 RFD’s for peer-to-peer connection using RFD GUI.
Baud Rate :57600
Air Speed :64
Net ID :3

when i tried to send mavlink messages using the RFD’s both are pairing and Green light in solid state and red light is blinking. But the messages are not transmitting. When i tried to connect and check the RFD’s in Mission planner i’m getting error. Here is the picture of the error. How to solve this error??

Hi @KK_424 -
Are you attempting to use two telemetry radios for communication between your control computer and a Navigator powered vehicle?
Can you share your parameters file? I’m assuming you’ve configured your autopilot parameters to use the serial port you’ve connected the telemetry radios too?

Hii @tony-white

Yes I’m using 2 RFD’s one is connected to the drone and another one is connected to the computer. On the drone I connected the RFD to the Telem 1 port and I’m using Cube Orange flight controller. Here I’m attaching the Parameters configuration I did using RFD900 GUI.

Note: When i changed the Baud rate of the RFD’s it’s working previously the RFD’s baud rate is 57600 once i changed the baud rate to 115200 it’s working. Messages are transmitting between the RFD’s and when i connect the RFD to computer in QGroundControl it’s not showing.

Hi, please try settings the RFDs to 115200 baud.

This issue is causing the baudrate on the ports to change to 115200.

1 Like

Hii @williangalvani

Thanks for your reply…

Yes, when i changed the baud rate from 57600 to 115200 communication issue resolved and messages are transmitting between the RFD’s. But with 115200 baud rate parameters are not displayed on the QGC. When i used 57600 parameters are displaying on the QGC. When i connected with USB cable also it’s showing parameters… How to solve this issue?

Hi @KK_424 ,

The fix got merged yesterday, can you give blueos master a try? the bug should be fixed there, which means you should be able to use 57600

Hii @williangalvani

Okay I will try.
Thanks for your reply…