RFD868-EU series and Holybro 433mhz Problems "connection loss"

Dear Sir or Madam,
we are currently having some problems using the Holybro433hz and RFD868x EU / RFD 868ux EU modules.
In our working setup (drone setup / vehicle setup) we had the same modules every time, two 868UX-EU modules, two 868X-EU modules or two Holybro 433mhz modules. We configured the RFD’s using the RFDTools app. Both had the same settings, like 155k baud rate etc… The RFD’s were flashing Orange / Green, which according to the manual means they are successfully bound.
When I try to get the connection via QGroundControl (via the Pixracer Pro Telem Port 1), there is a connection for about 3 seconds and then we get a “Communication Loss” displayed in QGC (FC Software PX4 and it is the Pixracer Pro).
This is the case with both RFD modules. The Holybro modules are solid green and flashing red. However, I can not connect to the modules via QGC, so there the respective com port that I had selected (checked via device manager the ComPort) does not establish the connection.

We have been working with the RFD modules and Holybro modules in conjunction with the Pixhawk for quite some time. However, we have not experienced these problems yet. Regarding the RFD’s, we have already been in exchange with RFD Design, but the exchange has not yet been crowned with success.

Interesting for you for the error analysis is:
System 1 (RFD868ux EU)
System 2( RFD868x EU or Holybro 433mhz)

On both independent systems the connection with the RFD modules does not work - although we did not make any settings in the Pixhawk on system 1. There we had only reset the RFD868x-EU (as ground station, the other one was already installed in the copter from the last application) because we needed it before for another purpose.
Also the RFD as well as the Holybro does not work on system 2, so both cannot connect.

My guess would still be that you have to adjust the USB port settings yourself (picture attached). When I connect the module and open the USB properties via the device manager, it says 9800 as the baud rate, do you have to change that for a successful connection as well, or is that not relevant to this?

Since we use the RFD’s in conjunction with the Pixhawks on a daily basis, our concern is very urgent and I would appreciate a timely response.

Thank you in advance for your effort.

Translated with DeepL Translate: The world's most accurate translator (free version)

Hi @Marcel, welcome to the Blue Robotics forum :slight_smile:

While Blue Robotics do contribute to QGroundControl, we are not the primary maintainers of it, and we only provide support for it for use with the ArduSub flight controller firmware, with BlueOS (or our older Companion Software) running on the onboard computer (in an underwater vehicle). Generally that involves a tether rather than a radio transmission system, so we have very limited experience with using QGroundControl with radio transmitters.

I’d suggest looking at the QGroundControl support documentation to find the most appropriate place for the support you’re after.