Home        Store        Learn        Blog

Raspbery pi wont boot from Ardusub. fails wiith recover4..elf message


List,

i have been trying to load the lattest Ardusub image on a sdcard and i am getting errors like those shown in thenabove image. i have tried 5 ad-cards including 3 right out of their packaging on 3 diffrent raspberry pis and till get then same issue. does amyone have a idea on how to resolve this issud?

Hi @Robi_Sen, welcome to the forum :slight_smile:

ArduSub is the firmware for the Pixhawk autopilot, which is different to and separate from the Companion Computer Software that goes on the Raspberry Pi.

Your picture also displays that you’re using a Raspberry Pi 4, which currently isn’t fully supported by our companion software. At the moment we only fully support Raspberry Pi 3B, not 3B+ or 4, but there’s a relatively major update coming in the next few months that will add full Raspberry Pi 4 support.

In the meantime, it is possible to use an RPi4 with the current software, but it requires some additional effort to set up, and there are a few issues with the installer script so some features may not be available. If you choose to continue with your RPi4 you can flash the SD card with a clean Raspberry OS Lite install, and then follow the instructions here to install the companion software.

Once you’ve got a Raspberry Pi with a working companion image on it I’d suggest you follow our software setup guide :slight_smile:

1 Like

Thank you for your reply. I did figure out the issue with the RPI4 and switched to an RPI3 that I have. I will look at your instructions on setting up the RPI4 but will move ahead with the RPI 3. Thank you again for your response.

1 Like