Raspberry Pi Camera video is flashing on and off about every five seconds

High All,

This post has been moved to the BlueROV2 and Ardu Sub Software Updates Forum. sike, moved back here - Jacob


I followed the steps outlined here to upgrade my pre June 2017 software and did encounter a problem with rewriting the ardusub-raspbian.img on the original SD card. It turns out that the original SD card was software protected against being overwritten and therefore Etcher could not overwrite the SD card with the updated ardusub-raspbian.img. I also could not reformat the SD card. So I went out and purchased another 16GB SD card that Etcher was able to successfully write to and verify that the ardusub-raspbian.img was indeed on the card. I was then able to update the ardusub software using the Companion Computer after the ardusubraspbian.img update.

I also updated to the latest version of BR’s QGC.

However, prior to updating the software the Raspberry Pi camera operated flawlessly. However, since the software updates the camera video is now flashing on and off approximately every 4 - 5 seconds.

Are there any adjustments I can make to stop this on and off flashing as Rusty has said that the new software “provides a means to quickly adjust and test the Raspberry Pi camera and video stream settings.”?


Hi Tom,

Regarding the SD card, did you check the MicroSD to SD card adapter to make sure the write protection switch was flipped the right way? It’s easy to flip that and prevent the card from being written properly. We don’t write protect any of our cards so I think that might be what happened.

On the camera, do you see any other disconnection issues, like the MAVlink connection dropping out? Or is it just the video? I’m not sure we’ve seen this happen regularly like this and I’ll have to defer to @Jacob for troubleshooting guidance.


Hi Rusty,

Thanks for the quick response, much appreciated.

Yes, I made sure multiple times that the SD card micro chip carrier had the switch in the unlocked position. It appears that some sort of write protect was built into the SD micro card directory.

I will do more testing today and see if the MAVlink connection is dropping out. I did notice that If I went to any of the other pages for a while and then back to the video page, the video would stay stable for several minutes before beginning to flash on and off again. All of the other QGC pages appear stable.

Also, I noticed that the green light next to the red power light on the Raspberry Pi was blinking in time with the video flashing on and off.


Hi Rusty,

I have been running the system now for about half an hour and there have been no MAVlink connection drop outs.

The video just appears to be starting and stopping every 3 - 5 seconds for some reason while all of the other pages are stable.

Is it possible to go back to my original SD card to see if the issue persists?

Tom C

Hi Rusty,

I think that I may have found the problem.

I when I unzip the ardusub-raspbian.img file and then try to open it, I get a message that the file is corrupted.

Maybe I should try downloading and unzipping it again?

Tom C

The green light is fine, the write protection is fine, and the img file is probably fine. If you are seeing anything at all in qgc, the image on the sd card is fine.

This is indicative of a communication/bandwidth issue. The issue is likely to be physical (loose connections) or with the client pc. Please follow the troubleshooting steps outlined here and let us know your results. Redirecting...


Thanks for the troubleshooting tips, much appreciated.

One question before I start troubleshooting the issue: why was the camera video stable with the pre June 2017 ardusub-raspbian image and not now with the updated ardusub-raspbian image?

As a test, can I use the pre June 2017 ardusub-raspbian image with the updated ardusub software and the latest BR version of QGC?

Tom C

You disassembled the ROV. When was the last time you used the ROV?

I don’t believe this will be helpful. Please do the troubleshooting steps I linked.


Problem solved.

I am using an older HP laptop that only has a 1024X768 display and I guess that the cpu and video processor could not accommodate the 1080p video data stream. Going to and setting the video Frame Size to 1024X768 resolved the issue. The video is now stable and very sharp.

I am going to buy a new laptop this weekend and have been looking at HP laptops with I3, I5, and I7 processors and it seems that only the HP laptops with the I7 processors have the 1440X1080 graphic displays.

To answer your other questions:

The BR2 has been on the shelf since April 2017 due to moving to a new location in FL and going through two hip replacement surgeries.

All of the connections are good and tight since I ran the BR2 with the pre June 2017 software prior to the software upgrades and the video was good and steady.

The bandwidth test on the Network page indicated almost 69Mbps for downloading and 61Mbps for uploading.

Thanks again for your troubleshooting tips. All I have to do now is to remember to set the camera Video Frame Size back to 1440X1080 when I get my new I7 laptop.:smile:

Tom C

Hi All,

It looks like a fairly fast laptop is necessary to view the 1080p video stream.

I purchased a HP I7 laptop with a fast video processor this last weekend and was able to view the video stream at both 768p and 1080p resolution without any disruption of the video stream.



Great @tciii, thank you for following up with your resolution. We do recommend an i5 or better cpu and ssd, but QGC will generally run well on most modern computers. It will depend on what other applications/processes are going at the same time.

I’m having the same video problem on a moderately capable computer. I went to use the companion configuration as suggested above and it allows me to change the values on the web interface but doesn’t implement the new values (as viewed in QGC running simultaneously). Is there a way to make these values persistent?
I’ve tried pushing all the buttons on the page (apply options, reboot, etc.) After a reboot, the video resolution is always at the original default value. I’ve tried running this interface with QGC running and with it not running.
Suggestions welcome. I will investigate things I can do with my video driver settings on the laptop as well, but this would be nice to get working.

I will withdraw my previous question due to user error. After a computer reboot, the companion web interface buttons are able to make persistent changes to the video parameters. Dropping the frame rate and resolution gets rid of the periodic grey-out of the video and reduces the video display latency. I also gave QGC a “high” priority through windows task manager and made that permanent by inserting that command into the starting shortcut. - instructions found here:

I hope that’s useful to somebody.

I’m having the same issue with our BR2 and our NUC pc CPU was running @ 100% Sidon as we booted QGC.

The specs weren’t great and it was only a £200 pc, now on the lookout for a laptop with better graphics and cpu. May I ask how the HP with i7 processor has performed?

Thanks Davie