QGroundControl Not Recording Video

“if you’re already recording the video”

I can’t seem to be able to start recording a video… I have updated Companion to 0.31, ArduSub to 4.0.3 and use the latest version of QGroundControl, but when I press the button to start video recroding, it stops immediately, without capturing anything.

Hi @AlexisGR, welcome to the forum :slight_smile:

We very recently changed our latest recommended version to v4.1.7 (please use the direct link - I’m not sure if the download links in our installation instructions have been updated to it yet), specifically to fix an issue like you’ve described. Are you able to try that version and see if it resolves the issue? :slight_smile:

If that doesn’t solve the issue, it would be helpful if you can

  1. go to the Application Settings (click the Q logo in the top left) then the Console page
  2. click “Set Logging” (bottom right), and turn on the ones that start with “Camera”
  3. restart QGC, and try to do a video recording once it’s reconnected to the vehicle
  4. return to the Console page, and click “Save App Log” (bottom left)
  5. upload the log file here so we can try to figure out what’s going wrong :slight_smile:
1 Like

Thanks for the ultra fast reply!
I already had version 4.1.7 installed. Still, when I load QGC, a message for a new version pops up!
In any case, I downloaded the installer from your link, which was identical to the one I had downloaded. Still, I re-installed, to be on the safe side.
I am a new user to the forum, so I can’t upload the log. I am sending a screenshot.
From what I can understand, it seems the App doesn’t have Write priviledges, which is strange, since I have admin rights as a user.

Yeah, that’s a known issue. I’m not sure if it’s because 4.2.0 exists (which we don’t recommend for using with ArduSub at this point), or because of a categorisation problem with the way the release was made. It’s a bit annoying, but shouldn’t cause any functional issues.

I’ve bumped up your trust level - log would be appreciated if possible :slight_smile:

That’s indeed strange - I’ve passed this on to our software team to investigate, although there won’t be a response until during the week (I just happened to be online and saw this post).

1 Like

alex_novideo.txt (2.8 KB)

I just uploaded the log, thanks for the trust bump! :slight_smile:
I will probably try QGC at my other laptop, but the problem is that it is an expensive gaming laptop and I don’t like the idea of taking it on a boat! :wink:

[Edit] Everything worked fine on the other laptop…I will probably format and re-install Windows on the faulty one. Still, it woulb be interesting to see if the support team can find any other solutions!

I found a way to record video through sharing the stream with VLC player, via another UDP port (found it in youtube!). Still, it would be great if I could use QGC only.

By the way, is there a way to display telemety data in the video?

[Edit] Since the video recording worked on my other laptop, I saw that there is an .ass file which displays telemetry data on the .mkv video, so the answer is obvious! :sunglasses:

once again! thank you very much for your time!

1 Like

With older QGC, (4.1.x) I made video recording work by not choosing “Nvidia decoder” but instead use “Force DirectX3D”
If that gives software team a clue for this case

1 Like

After the re-installation of Windows, everything worked like it should! Thank you for your time Eliot!

1 Like

hello, after a couple of tests, I decided to update my rov 2 with the new companion and everything worked fine and stable until I tried to record video in QGroundcontrol 4.1.6 and I couldn’t do it (I had foolishly tried everything except record video) when I pressed the record button does not activate and does not record, I tried several recent versions and none worked for me, any help would be greatly appreciated

Hi @seba,

Can you try QGC v4.1.7? It should hopefully fix the issue :slight_smile:


thanks for your help, problem solved :slight_smile:

1 Like