QGC Compass Problem

We ran into a strange problem today. We have successfully calibrated the compass and accelerometer.

Then we tested the stabilized mode and everything worked fine with no issues.

Today, however, the compass started to move in one direction continuously. Compass shows that although the robot is stationary, it is constantly turning left/right.

We changed the sd card of the raspberry after the calibration, does this cause a problem? But it has same version of ArduSub.

Or what could be the cause of this problem?


1 Like

Hi @ugurdemirezen,

This has also been reported elsewhere but I’m not sure what causes it. I’m waiting on a response from the software team on how to fix/avoid the issue and will get back to you.

Following up on this,

Hi Eliot,

Thank you for your answer.

It might be about the firmware but our ROV is working with same firmware for months. And
when we run the pixhawk away from the electronics it works well. But when we mount it in the electronic part the compass breaks down.

If you want to check if it’s bcause noise or interference I can send you images of our electronic part with e-mail (because of privacy reasons).


Hi, this is usually caused by gyro bias. you can try running the Gyro Calibration. it is exposed in latest QGC (daily), in the sensors tab.
Or you can try setting it to calibrate every boot ( INS_GYR_CAL = 1), but that doesn’t work well when booting from a boat, for example.

1 Like

Hi Willian,

We run the gyro calibration successfully, but the compass always changing.

I updated pixhawk’s and raspberry’s firmware.

Do you have any other suggestion?

If you want to check our firmware you can connect with teamwiever.


1 Like


Please share a dataflash log

You need to either arm or set LOG_DISARMED to 1 to have a log generated. either should work fine.

Yes! but it seems to be from the older beta. the latest one should show this in the summary page in QGC:


We had this problem again :frowning: . We had a test operation for 2 days. On the first day we used our ROV in manual mode only.

On the second day, we tried to Stabilize mode. After that gyro, compass, and depth values ​​started to change constantly in the wrong way.

Our ROV is about 100kg and we are using a heavy configuration.

It was a very important operation for us but we could not finish our tests because of this problem.

Is it about ardusub or pixhawk? If anyone has a suggestion I would be glad to listen.


Possibly a faulty gyroscope on the Pixhawk, as described in this recent topic? It may be useful if you’re able to provide a dataflash log and/or do your own log analysis to confirm if the behaviour is the same.