Home        Store        Docs        Blog

Problem with leveling horizon

(Jay Abraham) #1

im trying to level my horizon on QGC so the built-in gyroscope can realize that the rov is in an upright position but every time i try to level it, qgc says that the calibration failed. i also getting the same problem with calibrating the compass

0 Likes

#2

I don’t think this will help, but I had trouble calibrating the gyro by going a little too slow and found that it worked much better by getting a bit aggressive with it all the way through calibration. Worth a shot because it’s free and easy. The Pixhawk could also be having some issues. Aaaand of course make sure the battery is charged. How old is this unit?

0 Likes

(Jay Abraham) #3

just curious what you mean by being aggressive. also this is a new ROV build with reused electronics. also im not using a battery instead i’m using a power supply

0 Likes

#4

Just kind of moving faster and more continuous. I was handling it and moving slowly because it was expensive and I didn’t want to drop it or have the battery pop out and I was overly cautious and calibration failed, but then I took a firm grip with confidence and wrestled it around and worked on keeping the green bar moving as much as I could and that worked out great.

0 Likes

(Jay Abraham) #5

ohhhhh so you have to move the ROV around in all directions. i thought you had to keep it still so it could detect what the leveled position would be

0 Likes

#6

I should remember which is which, but thinking logically, calibrating the gyro is probably the one where you have to move it around all axis and the compass is probably the one where it has you set it flat, then the side, then top, etc. etc. There is text on the screen that guides you through it, just below the status bar when you click “next” or “start” or whatever it is.

0 Likes

(Jay Abraham) #7

that’s one of the problems though. i don’t get any text though when i’m leveling the horizon. it starts off by saying something on the lines of “leveling horizon calibration” and then when the green bar is like 90% of the way through, i get a yellow banner on the top area of QGC and it says Calibration failed

0 Likes

#8

Okay so I just connected mine and click “level horizon” and “ok” and the only weird thing is the text says “level horizon complete” before the green bar goes all the way across, but it does go all the way across after maybe ten seconds. With yours having issues I’d be tempted to reset the Pixhawk and start over. I haven’t done this, or had the need to, it’s just my default thought when things are getting screwy with anything electronic. I assume when you go to 192.168.2.2:2770/system and select “restore default parameters” and then fire up QGC for the first time afterwards it will prompt you to calibrate the accelerometer and then the compass as if it were being fired up for the first time. And then you can level horizon if you want. I say if you want because I don’t think that QGC prompts you to setup anything beyond the accelerometer and compass.

0 Likes

(Jay Abraham) #9

Isn’t there a reset button on the side of the pixhawk. Also what will reseting the pixhawk do? Will it just reset the gyroscope and the accelerometer or will it do more?

0 Likes

#10

I don’t think there’s a button. Reset will get rid of all parameters. I think it would make it like you had a new kit setting up for the first time.

0 Likes

(David Boulanger) #11

It is the reverse. Compass calibration is rotating on all axis and gyro calibration is laying it on all 6 sides and waiting for it to be still before moving on to the next side.

1 Like

(Jay Abraham) #12

ahhhhhhhhhhhhh gotcha

0 Likes

(Jacob) #13

If there are any outstanding issues here, please explain the current situation or question, and I can clarify.

1 Like

(Jay Abraham) #14

0 Likes

(Jay Abraham) #15

this is the problem im getting and i don’t know what to do

0 Likes

(Jay Abraham) #16

I tried to reboot my ROV but it is still not leveling

0 Likes

(Willian Galvani) #17

Hello Jay,

Can you try with BR QGroundControl 3.2.4-rev6?

Please also check in the Summary page that your ArduSub version is 3.5.3.

0 Likes

(Jacob) #18

@jjabraham what does the horizon indicator look like for you?

If it looks rotated 90 degrees from what it should be, you need to set the BOARD_ORIENTATION parameter to ‘Roll90’ (because the pixhawk is mounted sidways).

0 Likes

(Jay Abraham) #19

the Pixhawk is actually upside down so would i put it in Roll180. is there a link to an explanation of all the Roll option on the Ardusub installation guide book

0 Likes

(Jay Abraham) #20

thanks to your help, my ROV is leveled but every now and then, it malfunctions and the attitude indicator goes in all kinds of directions. BTW my depth sensor is also malfunctioning too. i tried rebooting it and i re imaged the pi but i’m still getting the same results. i have to re level the horizon to get it back in shape but it malfunctions again after a couple of minutes. what should i do. is my pixhawk defective?

0 Likes