Home        Store        Docs        Blog

Pixhawk Low PWM voltage output

Hello there,

So i’ve completed the initial setup for my new pixhawk and all seems to be good without any warnings but the motors start to spin very slowly after arming it. I’ve started measuring the output voltage of the motor channels without the ESC being connected. The multi-meter reads 1.25V forward, 0.75V backwards and 1V at neutral joystick position. That applies to all the 8 Main Ports.

I’ve previously calibrated the used joystick correctly, set the PWM ranges from 1100 to 1900 for the corresponding channels, set the throttle gain to 100%, Motor output type to be normal and all the other parameters are in their default values.

The Pixhawk has already enough power, sensing 12V from the connected power sense module. I’m expecting the PWM channel to output 2.5V at neutral position, 5V for full forward throttle and 0V for the reverse direction!!

The output from the Pixhawk is servo PWM, it works differently than what you think in your post. Here’s a Wikipedia article to get you started:

seems you sholud change your pwm type to brushed bipolar.
see this link:common-brushed-motors

It turns out that the BLHeli ESC settings must be modified first before calibration in order for the ESC to work with the T200 Thruster.

The “Motor Direction” set to “Bidirectional 3D” and “Low RPM Power Protect” set to “Off” as mentioned in the ArduPilot Docs.

https://ardupilot.org/rover/docs/thrusters.html?highlight=t100