Home        Store        Learn        Blog

Not able to connect Basic ESC to Pixhawk 2.1 using mission planner

Hello,

I am building a surface vessel which will be controlled through a Pixhawk 2.1 flight controller using Mission Planner. I am trying to connect 2 x Basic ESC (which are connected to 2 x T200 thrusters) but I am not getting any response. I did all the parameter changes recommended.

I tried following the instructions from this link https://ardupilot.org/rover/docs/thrusters.html, but the Basic ESC uses another firmware version.

Could anyone help me?

Thank you in advance

Hello,

Our ESCs use the BlHeli-S Firmware and come pre-configured for bidirectional operation. They expect a regular PWM instead of D-Shot, though.

What have you tried so far?

Thank you for your reply.
I applied the change to the parameter MOT_PWM_TYPE but it is still not working.
It gives me the following message:“Set parameter error. Ensure your version is AC3.3+.”

All firmware are updated.

The ESC is connected to the main out port 1 and it is powered on, the RF is connected correctly.
The MOT_PWM_TYPE is set to 0: Normal
MOT_PWM_FREQ 16 kHz.

The T200 thruster biped 3 times when turned on, but that is all.