Home        Store        Learn        Blog

Ping360 Static IP

Is it possible to set a static ip on the ping360?

Hi @craig,

Yes it’s possible, you can do that in the device manager screen:

And after that you can configure the IP address as dynamic or static:

Thank you Patrick. Do you know what software version is required? Our version of this software does not have that option.


Hi @cbulger,

You can always download the latest version on ping-viewer website: https://docs.bluerobotics.com/ping-viewer
Or repository: https://github.com/bluerobotics/ping-viewer#downloads-package

Hi @patrickelectric,

I just downloaded the latest software from the website but I still don’t see the static IP option. See attached images.


Hi Craig,

I’m sorry but I informed you the wrong version, this is a feature that was not released yet, please download our continuous version here: https://github.com/bluerobotics/ping-viewer/releases/tag/continuous

I downloaded Ping Viewer from that Continuous version that was updated on August 6th, and I still don’t see any way to set a static IP. I’m having a really hard time getting both Ping sonars to work, and I think it’s because they are always fighting over the exact same address. I also looked in the companion computer site and didn’t see a option to set IP address there either.

The network configuration is not possible if the device was found via companion, since companion communicate with Ping360 via serial port, ethernet configuration is not possible.

Please explain what you want to accomplish with that or what is your real problem.

If you want to have both Ping360 and Ping1D working simultaneously, you’ll need to open two ping-viewer instances.

It seems to work now. I think it started to work when I only used Ping1D at port 9090, then only used Ping360 at port 9092 on the second ping viewer. I did have 2 ping viewers open at the same time, but both of the sonar views would work for less than a minute after connecting before the sonar graphics would freeze. I think it was because I might have chosen both Ping sonars to use the same port.