Ping360 doesn't start - power issue?

Hi all,

first off, I am new to the forum and BlueRobotics products, and I am not by any means an expert on electronics, programming, etc. So please assume only base-level knowledge :slight_smile:

I have the following setup and problem:
My Ping360 will be connected to a battery fro power and to a computer via usb to run Pingviewer. I have had this working fine with a desktop setup and plan to now use a mini PC (Lattepanda) to put everything into a watertight housing to use the Ping360 idnependently from any ROV as stand-alone package.

I believe everything is ready, but now the Ping360 does not seem to power up at all. When I connected the Ping360 to the battery without any connection to a PC, I coukld feel it tickk and move insight. Now I get nothing. The battery gives 14V in its current state, so the voltage should be fine to power the Ping360. When I measrue the voltage on the battery at 14V and then connect the Ping360 the voltage read on on connection to the battery drops to about 3V. However, the Ping360 still seems to refuse to run. Is tehre any good way to check if te Ping360 actually gets to draw the power it needs? I am very hesistant to open the enclosure to avoid any leakage later on.

I have also tried an external power source (universal power adapter at 14-17V), but also with that the Ping360 does not show up in the Pingviewer, nor does it seem to fire or rotate. This is based on touching the Ping360 lightly, which a few days ago gave me a clear feeling of movement inside.

I would very much appreciate any tips on how to troubleshoot this problem.


Your voltage read of 3V is far to low, should at least be 11V (using too thin wires)
Where do you measure; on the battery or close to the Ping?
I never hear or feel the Ping 360 until it starts to spin, using PingViewer.

What you can do is measure both current and voltage.
You can use a lab power supply, or multimeters.
Measure as close to the Ping 360 as you can.
Then you can see what current draw you have.
Max current draw should be around 0,5 Amps at 12V

Hi Bo,

thanks a lot fo ryour reply!
Yes, 3V is far too low. The battery measures at 14V without a load on. I measure at the point at which the original cables from the Ping360 attach, that is, is close to the Ping360 as possible without cutting the original cable or opening the Ping360.

Leaving the multimeter on the connectors, I measure 14V, then in the exact moment when I attch the wires of the Ping360, this drops to 3V. I assume that means the Ping 360 draws from the battery. I will measure also current, as you suggest and report back.

What really confuses me is that this exact setup worked before, and I have not changed anything since then. I also had this connected to my normal PC, and everything worked fine a few days ago. Now I cannot fnid the Ping 360 in Pingviewer on that very PC. Nothing changed, still the Ping360 doesn’t show up. As said, I could feel the Ping360 move into action before - it takes a very light touch on the body to feel some slight vibrations (easier on the ping altimeter, which is even clearly audible). Now I get nothing.


Hi again,

unless I am measuring wrong, the current draw seems to be much too little. I measure about 0,9 mA. I assume the deciding factor, given a charge battery delivering 14V, is the Ping360, not any rstrictions of the battery? The battery I am using is a BlueRobotics Lithium-ion Battery (14.8V, 15.6Ah), so there should not be any shortage of power.


When Ping is not running, 1 mA could be right.
Are you measuring DC, and not AC?
Since you get a power drop to 3V somethiing is wrong, like:
-Bad cable that make that power drop, in that case you should still have 14V on the battery.
-Bad battery that can not supply power; test with another load, like a 12V light bulb.

Hi @LarsG,

If a 14V battery is dropping down to 3V when you connect a device to it then either there’s a short-circuit (in the cable or device) that’s drawing more current than the battery can provide (which can be dangerous), or the battery is damaged and has very little current capacity.

Hi all,

sorry for the long absence and thanks for your input! I just wanted to update this post, so anyone with similar problems gets the solution at least in my case. The problem turned out to be a bad connector. After exchanging all wires and connectors, everything works just fine :slight_smile:


1 Like