Home        Store        Learn        Blog

No Ping360 sonar comms after installing new PCB in sonar

Hello,
I had to install a new pcb in the ping360 sonar due to water ingress into the sonar housing and corrosion in the original pcb. I plugged the new pcb to the sonar head by following the instructions here:

Seems like the sonar is drawing power (approx 70mA @ 12V ) and there is a blinking red LED on the pcb, but the sonar is still not recognized in the sonar viewer software or in the system’s devices list (http://192.168.2.2:2770/system).

I would be happy to hear any troubleshooting tips on this one. Thanks.

First check you have the latest version of ping viewer installed, then try swapping 1 of the rs-485 pins, make sure you don’t swap the power wires, as no reverse polarity protection on the 360. (

1 Like

Thanks for this suggestion @murf :slight_smile:

@odedezra let us know how you go. I’ve asked internally if there’s anything else that might be causing the connection issue, and will get back to you.

Apparently this has already been sorted out via email, and was from a power supply issue :slight_smile:

Hi Eliot and Craig,
Thanks for your suggestions and sorry for my late response.
At the end it was a startup order issue;
In short, I powered the sonar from a desktop power supply to be able to monitor the current consumption and did not make sure to power both the ROV and the sonar at the same time. Apparently the sonar needs to be on or powered up at the same time as the ROV so the RPi will see that the sonar is there when the system is starting up. It took me a few trials and error to find this out. Now everything seems to be working fine.

Ahh yes, I think I had some issues with that previously. I’ll see if I can add a note about that in the troubleshooting section of the PingViewer docs :slight_smile:

Great to hear it’s ended up solved and working properly :slight_smile: